LinuxTV

News

2005-11-11   Deadline for V4L1 API

Video4Linux API version 1 is declared as obsolete, with a deadline marked as July/2006.

Version 2.6.3 had introduced a new API version, for beter handling video support, called V4L API version 2. The new API provides support for a wide range of video standards, including the several audio channels provided worldwide.

For now, both V4L1 and V4L1 APIs are provided by the main modules, but newer drivers should provide handling only for V4L2 API, and use v4l_compat_ioctl to handle calls to old API.

More details about V4L2 API can be found here.

mchehab