[linux-dvb] Re: Firmware (dvb-ttusb-dec-3000s.fw) unavailable.

Markus Posch markus at posch.at
Wed Apr 13 11:49:56 CEST 2005


jb at lemaitrezor.com schrieb:
> Hello,
> 
> you may try to put your firmware in /usr/lib/firmware, it worked for me on
> gentoo.
> 
> reguards,
> 
> jb
> 
> 
>>Hy @all.
>>
>>Now I had installet the release of kubuntu 5.04.
>>
>>but there is still this problem:
>>
>>when i connect the dec 3000 i got this in dmesg:
>>
>>Apr 13 09:15:46 localhost kernel: usb 3-1: new full speed USB device
>>using uhci_hcd and address 2
>>Apr 13 09:15:57 localhost usb.agent[8890]:      ttusb_dec: loaded
>>successfully
>>Apr 13 09:15:57 localhost kernel: ttusb_dec: Firmware
>>1.15<3>ttusb_dec_boot_dsp: Firmware (dvb-ttusb-dec-3000s.fw) unavailable.
>>Apr 13 09:15:57 localhost kernel: usb_unlink_urb() is deprecated for
>>synchronous unlinks.  Use usb_kill_urb() instead.
>>Apr 13 09:15:57 localhost last message repeated 3 times
>>Apr 13 09:15:57 localhost kernel: usbcore: registered new driver ttusb-dec
>>
>>the firmware has the right name and is placd in /usr/lib/hotplug/firmware.
>>
>>the script dvb.sh and the rules are added.
>>
>>but there is still no adapter and no frontent in /dev.
>>
>>in lsmod i got:
>>
>>Module                  Size  Used by
>>ttusb_dec              21320  0
>>dvb_core               81704  1 ttusb_dec
>>ttusbdecfe              3680  1 ttusb_dec
>>firmware_class          9984  1 ttusb_dec
>>video                  15972  0
>>usbhid                 31936  0
>>i2c_core               22320  1 i2c_i801
>>ehci_hcd               32708  0
>>uhci_hcd               32816  0
>>usbcore               119000  6
>>ttusb_dec,usb_storage,usbhid,ehci_hcd,uhci_hcd
>>
>>what is wrong?
>>please help me.
>>
>>greets
>>markus
>>
>>
>>_______________________________________________
>>linux-dvb mailing list
>>linux-dvb at linuxtv.org
>>http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>>
> 
> 
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 

thanks for the quick answer.
i put the firmware to /usr/lib/firmware but there is still the same 
message in dmesg.

do you (or anyone else) have another hint for me?

i tried to place the firmware on many diffrent places (on any place 
which i saw in firmware.agent) but no way.

greets
markus





More information about the linux-dvb mailing list