[linux-dvb] Twinhan DVB-T PCI

Manu Abraham manu at kromtek.com
Mon Apr 18 23:42:11 CEST 2005


Henrik Jönsson wrote:
> Henrik Jönsson wrote:
> 
>> > Henrik Jönsson wrote:
>> >> Hello
>> >> I've got a problem I hope someone can help me whit. I have a 
>> Twinhan DTV
>> >> Ter- CI split but I accidently did break the cabel between the CI-card
>> >> and the tv-card, anyway thats not the problem. When i do modprobe like
>> >> this:
>>
>> >> DVB: registering new adapter (bttv0).
>> >> dst_check_ci: unable to recognize  or DTT-CI
>> >> dst_check_ci please email linux-dvb at linuxtv.org 
>> <http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb> with this 
>> type in
>> >> DST type : satellite
>> >> DST type flags : 0x4 symdiv
>> >> DVB: registering frontend 0 (DST DVB-S)...
>> >>
>> >> My problem is now why wont the frontend register it as a DVB-T card.
>> >> everthing else seems to be right except thoose last lines.
>> >>
>> >
>> > I think you are using a bit old driver. Can you please update to the
>> > latest dvb-kernel CVS and let know how it proceeds.. ?
>> >
>> > BTW, which card are you using ? I mean the model number ?
>> >
>> >
>> > If it is a new card, not identified by the driver, it would just say
>> > that ..
>> >
>> > Manu
>>
>> Sure i'll try that after this weekend and get back on how it went, i 
>> will asso get back on the model number thing =o) (not home this weekend)
>>
>> btw im using SuSE 9.2 with kernel 2.6.11.7 the only thing i've done 
>> besides upgrading the kernel is used the bttv-freeze patch.
>>
>> Best Regards
>>    Henrik Jönsson
>>
>>
> Hi
> now i've totaly screwed it up :-/

Looks so at least .. SuSE is one big pain, i realized it practically..

> when i try to load the bttv driver by doing *modprobe bttv -v i2c_hw=1 
> card=0x71* I'll get:
> insmod /lib/modules/2.6.11.7/kernel/drivers/media/video/bttv.ko i2c_hw=1 
> card=0x71
> FATAL: Error inserting bttv 
> (/lib/modules/2.6.11.7/kernel/drivers/media/video/bttv.ko): Unknown 
> symbol in module, or unknown parameter (see dmesg)
> 
> when i doing a dmesg this turns up:
> bttv: disagrees about version of symbol tveeprom_read
> bttv: Unknown symbol tveeprom_read
> bttv: disagrees about version of symbol tveeprom_read
> bttv: Unknown symbol tveeprom_read
> bttv: disagrees about version of symbol tveeprom_read
> bttv: Unknown symbol tveeprom_read
> bttv: disagrees about version of symbol tveeprom_read
> bttv: Unknown symbol tveeprom_read
> 
> So now all i have to do is figure out what i did wrong when i tryed to 
> update the modules.
> btw the modelnumber on my tvcard is 3040. it was atleast what it sayed 
> on the box but if it doesn't make sence get back to me and i'll try to 
> find it out

The 3040 works with the latest dvb-kernel CVS patches and the 
bttv-freeze patch on kernels > 2.6.10-rc2.


Manu







More information about the linux-dvb mailing list