[linux-dvb] Mencoder, no-go muxes and picture aspect

Nico Sabbi nsabbi at tiscali.it
Thu Apr 28 13:33:31 CEST 2005


Simon Baxter wrote:

>>> Hi group
>>>
>>> I've been using mplayer's Mencoder to encode streams from my WinTV 
>>> NovaT card on the fly, with varied results.  I start a tzap to tune 
>>> the card, then mencode it.
>>
>>
>>
>>
>> why don't you use directly
>>
>> $ mencoder dvb:// ...
>>
>> instead?
>
>
> ...snip
> Not sure how to get this working :
> [file] No filename
> Failed to open dvb://
> Cannot open file/device.
>
copy channels.conf to ~/.mplayer

>
>>> ...and nothing further.  No "TS file format detected", no avi 
>>> created, no nothing!!
>>>
>>> How come?
>>
>>
>>
>> nothing is coming out of the card.  Maybe the card isn't locking the 
>> frequency
>
>
> It looks ok :
> [root at media ~]# /root/bin/tzap -c /root/.tzap/channels.conf -r 'five'
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> tuning to 561833330 Hz
> video pid 0x0000, audio pid 0x0caa
> status 01 | signal 3838 | snr f763 | ber 0000089c | unc 00000000 |
> status 01 | signal 3939 | snr f763 | ber 0000089c | unc 00000000 |
> status 1f | signal 3a3a | snr ffd6 | ber 00000029 | unc 00000000 | 
> FE_HAS_LOCK
> status 1f | signal 3939 | snr ffff | ber 00000000 | unc 0000000b | 
> FE_HAS_LOCK
> status 1f | signal 3939 | snr ffff | ber 00000000 | unc 00000000 | 
> FE_HAS_LOCK
>
>
>>> 2)  Has anyone had any luck changing the aspect with Mencoder?  The 
>>> avi is too vertically stretched.  I had tried the following
>>> mencoder /dev/dvb/adapter0/dvr0 -force-avi-aspect 3.0 -ovc lavc 
>>> -lavcopts vcodec=mpeg4:vpass=1 -oac copy -o 
>>> /usr/video/Test25-9_2_280405.avi
>>
>>
>> what does mplayer say when you play it? 3.0 is allowed but a bit 
>> strange, though
>
>
> hmm, not sure.  Am recording samples on the linux box and watching 
> them on Windows Media Player Classic.


so wimp doesn't even follows M$'s specifications :)

>
> Another weird thing, even though I'm "-force-avi-aspect 3.0", I'm 
> getting the following :
> [root at media video]#file Test_asp3_280405.avi
> Test_asp3_280405.avi: RIFF (little-endian) data, AVI, 704 x 576, 25.00 
> fps, video: DivX 4, audio: (stereo, 48000 Hz)
>
> And, "-force-avi-aspect 2.0", I'm getting the following :
> [root at media video]# file Test_asp2_280405.avi
> Test_asp2_280405.avi: RIFF (little-endian) data, AVI, 704 x 576, 25.00 
> fps, video: DivX 4, audio: (stereo, 48000 Hz)
>
> Should the resolutions be the same with a different aspects?
>
>
>

it's irrelevant, file is not updated or discards those infos





More information about the linux-dvb mailing list