[linux-dvb] Last rev of skystar-usb, still compatible with linux dvb driver ?

Patrick Boettcher patrick.boettcher at desy.de
Thu Aug 18 15:16:11 CEST 2005


Hi,

On Wed, 17 Aug 2005, Lavoie.S wrote:
> i'm trying to get working my new dvb-s technisat skystar-USB box in my 667mhz 
> macintosh powerbook G4, using the last Mandriva-Linux-2005-Limited-Edition 
> distro for ppc with 2.6.13-rc5 custom made kernel. Unfortunately, after 
> several days of trials i'm still running into trouble, the reason that's why 
> i claim some helps and advices from the linuxtv community :
> [..]
> ohci_hcd and address 3

> Aug 17 18:12:40 localhost kernel: b2c2-flexcop: unkown FlexCop Revision: 8. 
> Please report the linux-dvb at linuxtv.org.

1st problem.

> Aug 17 18:12:40 localhost kernel: b2c2-flexcop: MAC address = 
> 00:d0:d7:0c:b8:1c

Is this MAC address correct?

> Aug 17 18:12:41 localhost kernel: flexcop_usb: submitting urb 0 failed with 
> -90.

2nd problem.

> It's clear that the device refused to work, although the modules were loaded 
> correctly. I suspect but i'm not sure that technisat has changed somehow the 
> hardware in this newest revision of the model, or may be i forget some 
> patches to apply to the dvb driver...I would be pleased if someone can help 
> me to found the origin of my troubles.

So the innards of that box (plastic case) are not different to the older 
revision (metal case).

So the first problem for you is, that I recently "fixed" an 
big/little-endian issue for the flexcop-chip when running on 
big-endian-hardware such as PPC.

Unfortunately this change is apparently wrong when operating an 
flexcop-based USB box on a PPC. (the first problem from above) The 
big-endian-issue is checked only at compile-time and because the PCI and 
the USB driver are using the same flexcop-chip-driver. It's working 
correctly for the PCI card on PPC...

In the meantime I learnt that the flexcop-register-stuff I wrote for the 
flexcop-chips is not optimal... especially when looking at the 
endian-issues that can take place.

And it gets worse: I don't even have an idea how to fix it for you, 
without breaking support for the PCI card on PPC.

You can try editing manually the flexcop-reg.h

and substitute this line
     #include "flexcop_ibi_value_be.h"
with
     #include "flexcop_ibi_value_le.h"
and try again.

regards,
Patrick.

--
   Mail: patrick.boettcher at desy.de
   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/





More information about the linux-dvb mailing list