[linux-dvb] DViCO FusionHDTV 5 lite corrupt when PVR-350 is recording, concurrent recording with PVR-500- no problems

mrwester mrwester at gmail.com
Mon Dec 12 04:24:28 CET 2005


Hi-

I started this as a mythtv thread, trying to figure out why some recordings
with my new DViCO FusionHDTV 5 lite are corrupt.

My mythtv system has 1xHauppauge PVR-350, 1xHauppauge PVR-500 using ivtv 0.4,
and a newly added DViCO FusionHDTV 5 Lite using DVB drivers from CVS of
about a week and a half ago with kernel 2.6.14.   1x200GB seagate+1x300GB
seagate HD LVM with XFS for /video and 1x40GB seagate for FC4 OS. I have DMA
enabled. DVI out via fx5200 at 1280x768.  Chaintech nforce2 mobo, AMD2900
with 1gb ram.

All 4 tuners can capture on their own with no problems.  I can capture with
all 3 Hauppauge tuners at the same time no problems.  Trying to capture with
the FusionHDTV 5 lite while concurrently capturing with the PVR-500 tuners
(either one or both)  results in normal recordings.   The only time I get
corrupt recordings with the FusionHDTV 5 lite, is if I am concurrently
trying to record with the PVR-350.  The recordings just have some random
scrambled bars, squares.  Audio seems unaffected.  Nothing shows up in dmesg
or mythtv logs.

I've tried removing the PVR-500, and all kinds of combinations of slots.
The FusionHDTV5 lite does not share an IRQ address with either of the
PVR-xxx cards.  Any ideas?  Any ideas where to look?  Relevant parts of
dmesg from card init follows.  Thanks,

Mike
-------------------------------------------------
Linux video capture interface: v1.00
ivtv:  ==================== START INIT IVTV ====================
ivtv:  version 0.4.0 (tagged release) loading
ivtv:  Linux version: 2.6.14-1.1637_FC4 686 REGPARM 4KSTACKS gcc-4.0
ivtv:  In case of problems please include the debug info
ivtv:  between the START INIT IVTV and END INIT IVTV lines when
ivtv:  mailing the ivtv-devel mailinglist.
ivtv0: Autodetected WinTV PVR 350 card (iTVC15 based)
ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 11
ACPI: PCI Interrupt 0000:01:0a.0[A] -> Link [LNK1] -> GSI 11 (level, low) ->
IRQ 11
ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
ivtv0: i2c attach to card #0 ok [client=tveeprom, addr=50]
tveeprom 2-0050: Hauppauge model 48132, rev K168, serial# 7520207
tveeprom 2-0050: tuner model is LG TAPE H001F MK3 (idx 68, type 47)
tveeprom 2-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 2-0050: audio processor is MSP4448 (idx 27)
tveeprom 2-0050: decoder processor is SAA7115 (idx 19)
tveeprom 2-0050: has radio, has IR remote
tuner 2-0061: chip found @ 0xc2 (ivtv i2c driver #0)
ivtv0: i2c attach to card #0 ok [client=(tuner unset), addr=61]
saa7115 2-0021: saa7115 found @ 0x42 (ivtv i2c driver #0)
ivtv0: i2c attach to card #0 ok [client=saa7115, addr=21]
saa7127 2-0044: saa7127 found @ 0x88 (ivtv i2c driver #0)
ivtv0: i2c attach to card #0 ok [client=saa7127, addr=44]
msp3400 2-0040: chip=MSP4448G-A2 +nicam +simple +simpler +radio mode=simpler
msp3400 2-0040: msp34xxg daemon started
ivtv0: i2c attach to card #0 ok [client=MSP4448G-A2, addr=40]
tda9887 2-0043: chip found @ 0x86 (ivtv i2c driver #0)
ivtv0: i2c attach to card #0 ok [client=tda9887, addr=43]
ivtv0: loading /lib/modules/ivtv-fw-enc.bin
ivtv0: loading /lib/modules/ivtv-fw-dec.bin
ivtv0: Encoder revision: 0x02050032
ivtv0: Decoder revision: 0x02020023
ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
ivtv0: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
ivtv0: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
ivtv0: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB
total)
ivtv0: Create encoder radio stream
ivtv0: Allocate DMA decoder MPEG stream: 16 x 65536 buffers (1024KB total)
ivtv0: Allocate DMA decoder VBI stream: 512 x 2048 buffers (1024KB total)
ivtv0: Create decoder VOUT stream
ivtv0: Allocate DMA decoder YUV stream: 24 x 43200 buffers (1024KB total)
ivtv0: loading /lib/modules/ivtv_init_mpeg.bin
tuner 2-0061: type set to 47 (LG NTSC (TAPE series))
ivtv0: Initialized WinTV PVR 350, card #0
ivtv:  ======================  NEXT CARD  ======================
ivtv1: Autodetected WinTV PVR 150 card (iTVC16 based)
ACPI: PCI Interrupt Link [LNK4] enabled at IRQ 9
PCI: setting IRQ 9 as level-triggered
ACPI: PCI Interrupt 0000:02:08.0[A] -> Link [LNK4] -> GSI 9 (level, low) ->
IRQ 9
ivtv1: Unreasonably low latency timer, setting to 64 (was 32)
ivtv1: i2c attach to card #1 ok [client=tveeprom, addr=50]
tuner 3-0060: TEA5767 detected.
tuner 3-0060: chip found @ 0xc0 (ivtv i2c driver #1)
ivtv1: i2c attach to card #1 ok [client=(tuner unset), addr=60]
tuner 3-0060: type set to 62 (Philips TEA5767HN FM Radio)
tuner 3-0061: chip found @ 0xc2 (ivtv i2c driver #1)
ivtv1: i2c attach to card #1 ok [client=(tuner unset), addr=61]
tda9887 3-0043: chip found @ 0x86 (ivtv i2c driver #1)
ivtv1: i2c attach to card #1 ok [client=tda9887, addr=43]
tveeprom 3-0050: Hauppauge model 23552, rev D492, serial# 7855692
tveeprom 3-0050: tuner model is Philips FQ1236A MK4 (idx 92, type 57)
tveeprom 3-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 3-0050: second tuner model is Philips TEA5768HL FM Radio (idx 101,
type 62)
tveeprom 3-0050: audio processor is CX25843 (idx 37)
tveeprom 3-0050: decoder processor is CX25843 (idx 30)
tveeprom 3-0050: has radio, has no IR remote
ivtv1: This is the first unit of a PVR500
cx25840 3-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #1)
spurious 8259A interrupt: IRQ7.
cx25840 3-0044: loaded /lib/modules/HcwMakoA.ROM firmware (14264 bytes)
ivtv1: i2c attach to card #1 ok [client=cx25840, addr=44]
wm8775 3-001b: chip found @ 0x36 (ivtv i2c driver #1)
ivtv1: i2c attach to card #1 ok [client=wm8775, addr=1b]
ivtv1: Detected a TEA5767 radio tuner. Enabling radio support.
ivtv1: loading /lib/modules/ivtv-fw-enc.bin
ivtv1: Encoder revision: 0x02050032
ivtv1: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
ivtv1: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
ivtv1: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
ivtv1: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB
total)
ivtv1: Create encoder radio stream
tuner 3-0061: type set to 57 (Philips FQ1236A MK4)
ivtv1: Initialized WinTV PVR 500 (unit #1), card #1
ivtv:  ======================  NEXT CARD  ======================
ivtv2: Autodetected WinTV PVR 150 card (iTVC16 based)
ACPI: PCI Interrupt 0000:02:09.0[A] -> Link [LNK1] -> GSI 11 (level, low) ->
IRQ 11
ivtv2: Unreasonably low latency timer, setting to 64 (was 32)
ivtv2: i2c attach to card #2 ok [client=tveeprom, addr=50]
tuner 4-0061: chip found @ 0xc2 (ivtv i2c driver #2)
ivtv2: i2c attach to card #2 ok [client=(tuner unset), addr=61]
tda9887 4-0043: chip found @ 0x86 (ivtv i2c driver #2)
ivtv2: i2c attach to card #2 ok [client=tda9887, addr=43]
cx25840 4-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #2)
cx25840 4-0044: loaded /lib/modules/HcwMakoA.ROM firmware (14264 bytes)
ivtv2: i2c attach to card #2 ok [client=cx25840, addr=44]
wm8775 4-001b: chip found @ 0x36 (ivtv i2c driver #2)
ivtv2: i2c attach to card #2 ok [client=wm8775, addr=1b]
tveeprom 4-0050: Hauppauge model 23552, rev D492, serial# 7855692
tveeprom 4-0050: tuner model is Philips FQ1236A MK4 (idx 92, type 57)
tveeprom 4-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 4-0050: second tuner model is Philips TEA5768HL FM Radio (idx 101,
type 62)
tveeprom 4-0050: audio processor is CX25843 (idx 37)
tveeprom 4-0050: decoder processor is CX25843 (idx 30)
tveeprom 4-0050: has radio, has no IR remote
ivtv2: This is the second unit of a PVR500
ivtv2: Correcting tveeprom data: no radio present on second unit
ivtv2: loading /lib/modules/ivtv-fw-enc.bin
ivtv2: Encoder revision: 0x02050032
ivtv2: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
ivtv2: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
ivtv2: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
ivtv2: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB
total)
tuner 4-0061: type set to 57 (Philips FQ1236A MK4)
ivtv2: Initialized WinTV PVR 500 (unit #2), card #2
ivtv:  ====================  END INIT IVTV  ====================
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt 0000:01:07.0[A] -> Link [LNK2] -> GSI 5 (level, low) ->
IRQ 5
bttv0: Bt878 (rev 17) at 0000:01:07.0, irq: 5, latency: 32, mmio: 0xe4000000
bttv0: detected: DViCO FusionHDTV 5 Lite [card=135], PCI subsystem ID is
18ac:d500
bttv0: using: DViCO FusionHDTV 5 Lite [card=135,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
tuner 5-0061: chip found @ 0xc2 (bt878 #0 [sw])
tda9887 5-0043: chip found @ 0x86 (bt878 #0 [sw])
bttv0: using tuner=64
tuner 5-0061: type set to 64 (LG TDVS-H062F/TUA6034)
bttv0: registered device video3
bttv0: registered device vbi3
bttv0: add subdevice "dvb0"
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:01:07.1[A] -> Link [LNK2] -> GSI 5 (level, low) ->
IRQ 5
bt878(0): Bt878 (rev 17) at 01:07.1, irq: 5, latency: 32, memory: 0xe4001000
DVB: registering new adapter (bttv0).
DVB: registering frontend 0 (LG Electronics LGDT3303 VSB/QAM Frontend)...
ACPI: PCI Interrupt Link [LUB2] enabled at IRQ 11
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20051211/326b8b74/attachment-0001.htm


More information about the linux-dvb mailing list