[linux-dvb] twinhan bttv hang bug in kernel 2.6.13

Manu Abraham manu at kromtek.com
Wed Jul 20 11:03:09 CEST 2005


Michael Krufky wrote:
> Manu Abraham wrote:
> 
>>>>>> It seems to me as if this bug has resurfaced again. I had no 
>>>>>> problems loading bttv with my twinhan VP1030A with the 2.6.12 
>>>>>> kernel (actually patched for gentoo-sources, but I don't think 
>>>>>> there were any bttv related patches). When trying to upgrade to 
>>>>>> either 2.6.13-rc3 or 2.6.13-rc3-mm1 I was getting a hang when 
>>>>>> loading bttv, both from the kernel vedeo4linux tree and from the 
>>>>>> latest cvs (18/7/2005). I applied the patch Manu posted months ago 
>>>>>> from 
>>>>>> http://www.linuxtv.org/pipermail/linux-dvb/attachments/20050404/00967085/bttv-cards.c-0001.bin 
>>>>>> to the video4linux cvs source compiled againt 2.6.13-rc3-mm1 and 
>>>>>> the problem was fixed.
>>>>>>
>>>>>> Just thought that anyone else crawling this list for fixed might 
>>>>>> want to know. Did the fix not make it into the video4linux cvs 
>>>>>> tree ? (the patch applied cleanly) 
>>>>>
>>>>>
>>>> There is a better patch. It probably got lost because it was
>>>> applied to the kernel which v4l was maintainer- and CVS-less.
>>>
>>>
>>> Any idea whether the i2c timing patch also got lost ?
>>
>>
>> It seems only the bttv_reset_audio bugfix only got lost. But that went 
>> mainline too, IIRC, maybe never got back to v4l CVS ..
> 
> 
> Looks like it's been taken out of 2.6.13 ... probably an accidental 
> regression... When I have time later on I will send this over to 
> Andrew.  For now, I just applied this to video4linux cvs:  

Cool.


Manu




More information about the linux-dvb mailing list