[PATCH] Re: [linux-dvb] Twinhan fails horizontal initial scan

Manu Abraham manu at kromtek.com
Mon Jun 20 16:59:03 CEST 2005


Allan Stirling wrote:
> Manu Abraham wrote:
> 
>> Islam Amer wrote:
>>
>>> Hi all. First of all I'd like to thank you for all your efforts. I am 
>>> a happy twinhan user :) , I had reported earlier that my card
>>> didn't work on linux. I am now using it perfectly with 2.6.12-rc6-mm1
>>>
>>> I figured out all the stuff about scan and szap and mplayer. I can scan
>>> transponders with vertical polarization, and watch channels on them that
>>> have vertical polarization perfectly.
>>>
>>> But horizontal scans fail and even if I write channel information
>>> manually szap or mplayer fail to tune.
>>>
>>
>> Can you check whether the attached patches fixes that.. patches to be 
>> applied in the incremental order only..
>>
>> Should be applied either to a vanilla 2.6.12, since all CVS changes 
>> for the dst went in to mainline..
>>
>> Or can be applied against the latest CVS, but would require the bttv 
>> patches too, to work properly
> 
> Tried these patches. Another (budget) card gives the following:
> 
> 10714 MHz H | signal 48568 | snr db33 | ber 00000000 | unc 00000000 | LOCK
> 10729 MHz V | signal 49921 | snr dfec | ber 00000000 | unc 00000000 | LOCK
> 10743 MHz H | signal 46722 | snr df0e | ber 00000000 | unc 00000000 | LOCK
> 

What application are you using to zap ? Doesn't look like szap ...

> In less than a second per transponder.
> 
> With a virgin 2.6.12, I get locks on vertical channels only (reasonably 
> fast, with no errors in the log that I remember). Horizontal channels 
> don't tune.
> 
> With these patches, I get no locks at all :(
> 
> This is with a DSTCI card...
> 
>

I get like this on my DST-CI,

[root at deploy szap]# ./szap -a 0 -c ~/channels.conf -r -x "TMC2"
reading channels from file '/root/channels.conf'
zapping to 7 'TMC2':
sat 0, frequency = 11996 MHz H, symbolrate 27500000, vpid = 0x00cf, apid 
= 0x0133
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
zap_to: Polarity=[0]
Sat Number=[0]
status 1f | signal 5700 | snr 19a1 | ber fffffffe | unc fffffffe | 
FE_HAS_LOCK

Strange .. Dominique reported that his card (DST-CI) worked perfectly 
alright, a while earlier ..


Ok, are you able to scan, i mean do you get a list of channels ... ?
The lock flag what you mean, has not changed at all when you do a zap..

Dominique, can you give it a shot and see what's the status on your DST-CI ?


Manu






More information about the linux-dvb mailing list