[linux-dvb] Problems with twinhanDTV Sat-CI and new HlCI Api

Manu Abraham manu at kromtek.com
Thu Jun 23 16:56:22 CEST 2005


sigmund at snap.tv wrote:
> sigmund at snap.tv wrote:
>>>Hi,
>>>I'm trying to make a TwinhanDTV Sat-CI card work with cam and the new api, 
>>>but have a few problems. I can't say if all these are related, and I'm not 
>>>sure what more info should be supplied, but here goes:
>>>
>>>*Scanning works with dvbscan, and tuning works with szap, but no data comes 
>>>out of dvr0, even with -r and -x in various combinations and positions for 
>>>szap. I do however get FTA channels with vlc(which does it's own tuning).
>>>
>>try using test_dvr and see whether the same problem persists in 
>>dvb-apps/test
> works. 0x2000 gets lots of data, using a video pid gets some data, pat and 
> pmt pids get no data as long as I care to wait, but this is probably because 
> test_dvr doesn save anything before it has 65535 bytes 
> 
>>>*I've tried to replicate the calls of ca_zap inside vlc's dvb module, and 
>>>all seems to work, however the channel stay scrambled.
>>>
>>Let's stick on to a minimalistic thing to get this going else, would be 
>>a real pain ..
>>
>>Try running ca_zap alone, you might not be able to identify anything at 
>>all if the initial problems are not solved ..
> ca_zap does not finish, even when run before any of my code after a clean 
> reboot. There is nothing interresting in dmesg.
> 
>>Which provider is it ?..  Some providers even if they do descryption at 
>>Program level, the have all the descriptors at Stream level . TPS is 
>>known for that . In this case the descriptors from the Stream level have 
>>to be moved to Program level ..
> Telenor/canal digital, I do not know how they implement this stuff.
>>This thing i have not implemented yet ..
> That's ok, I heard there is a hacked version of ca_zap flowing around that 
> does this. Is this correct? Could the hacks be integrated as an option 
> perhaps?

That ca_zap version was based on the original monolithic version, after 
that i did quite some factorization of the app. I think Dominique is 
still using the hacked version for TPS, as that hack has not yet gone in ..


>>Try to get a dvbsnoop output for the PAT and PMT
> I will try that, I'll be back with the information.
>>>I hope this information can be of help, and can help someone find give me a 
>>>hint as to what is wrong.
>>>
>>>As a side note, I've had several problems with these drivers, after some time 
>>>the signal strength and SNR values returned goes to 0000 in szap, and some 
>>That's okay for the moment, nothing to get upset ..
> Not upset, just mentioning it in case it might be related. I assume things 
> will play nice once I figure out how to use them.
>>>large negative value in vlc, even though tuning works. And after some more 
>>>time tuning stops working. Even though the tuning calls complete without error
>>>the data returned are still from the old transponder. Reloading the drivers 
>>>sometimes help, other times a reboot is needed.
>>Hmm .. junk data was written to the card, the MCU crashed .. most 
>>probably ..
> A reboot should fix that? Or is there some utility to reset/jump start it 
> again?
> 
> Thanks for the help this far.
> 

Manu




More information about the linux-dvb mailing list