[linux-dvb] Firmware upload failed

Johannes Adams johannes.adams at gmx.net
Thu Jun 30 18:38:14 CEST 2005


Hi there!
Since some time I try to use my PC-Card from Medion (it says "Medion
TV-Tuner 7134" on it) which is recongnised as a Philips TDA10046H DVB-T.

Whenever I try to use the card with any program trying to access the DVB
card, I get the following messages in my logfiles:

tda1004x: waiting for firmware upload (dvb-fe-tda10046.fw)...
tda1004x: using firmware v20
tda1004x: firmware upload complete
tda1004x: firmware upload failed

In general the hotplug-subsystem works fine on my system, as I use it as
well for WLAN (which requires firmware as well).

I hope someone may help me with this - I have no idea why the firmware is
not loaded.

Some more information about my system:

Kernel 2.6.12.1
Debian unstable
Firmware generated with get_dvb_firmware

Here's the important part of the dmesg concerning the card:

saa7130/34: v4l2 driver version 0.2.12 loaded
saa7134[0]: subsystem: 16be:0003, board: Medion 7134
[card=12,autodetected]
saa7134[0]: board init: gpio is 0
saa7134[0]: i2c eeprom 00: be 16 03 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
saa7134[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 1f 02 51 96 2b
saa7134[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
tuner 0-0061: chip found @ 0xc2 (saa7134[0])
tuner 0-0061: type set to 38 (Philips PAL/SECAM multi (FM1216ME MK3))
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7134[0]: registered device radio0
DVB: registering new adapter (saa7134[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: waiting for firmware upload (dvb-fe-tda10046.fw)...
tda1004x: using firmware v20
tda1004x: firmware upload complete
tda1004x: firmware upload failed

I hope you can help me somehow!

Thanks
Johannes






More information about the linux-dvb mailing list