[linux-dvb] Problem with scanning using latest cx88 build (Nova-T)

Sid Boyce sboyce at blueyonder.co.uk
Thu Mar 3 04:16:27 CET 2005


Roger James wrote:
> I have just updated to the latest cx88 driver (video4linux-20050302) and 
> it has broken my Myth setup. Myth has deleted all its PIDs from the 
> database (I guess that is a myth problem).
> 
>  
> 
> I cannot seem to get any rescans to work to get the PIDs back again. The 
> myth rescan just hangs (interruptibly) and never completes.
> 
> If I use tzap to tune to a channel that works fine and I get lock, but 
> If  I then  run scan then  I get the a “filter timeout” on PIDS 0 and 11.
> 
>  
> 
> Anyone got any ideas. What has changed from the builds of about 1 month 
> ago. It was all working then. (I really must learn to leave well alone L ).
> 
>  
> 
> Am I missing some extra driver config now.
> 
>  
> 
> Roger
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

With 2.6.11 and the same snapshot with kaffeine-dvb, I can't get a 
display or audio. The snapshot builds. The only difference from the 
working 2.6.10 + video4linux-20050120 is the or51132 module which seems 
to require firmware - not needed with this card. From dmesg ---
bttv: driver version 0.9.15 loaded
bttv: snapshot date 2005-03-02
bttv: using 8 buffers with 2080k (520 pages) each for capture
kobject_register failed for v4l1_compat (-17)
  [<c020a421>] kobject_register+0x51/0x60
  [<c0135b47>] mod_sysfs_setup+0x57/0xb0
  [<c0136de1>] load_module+0x971/0xa60
  [<c0136f16>] sys_init_module+0x46/0x1e0
  [<c0150f08>] sys_munmap+0x48/0x70
  [<c010305d>] sysenter_past_esp+0x52/0x75
cx8800: Unknown parameter `radio'
cx2388x dvb driver version 0.0.4 loaded
cx2388x: snapshot date 2005-03-02
cx88[0]: subsystem: 0070:9002, board: Hauppauge Nova-T DVB-T 
[card=18,autodetected]
cx88[0]: hauppauge eeprom: model=90002, tuner=76
cx88[0]: registered IR remote control
ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18
ACPI: PCI interrupt 0000:01:08.2[A] -> GSI 18 (level, high) -> IRQ 18
cx88[0]/2: found at 0000:01:08.2, rev: 5, irq: 18, latency: 32, mmio: 
0xe5000000
cx88[0]/2: cx2388x based dvb card
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 0 (Hauppauge Nova-T DVB-T)...

Modules loaded.
---------------
evdev                   9152  0
cx88_dvb                7300  0
cx8802                  9220  1 cx88_dvb
mt352                   7940  1 cx88_dvb
or51132                10692  1 cx88_dvb
video_buf_dvb           6276  1 cx88_dvb
dvb_core               77224  1 video_buf_dvb
cx22702                 9732  1 cx88_dvb
dvb_pll                 5188  3 cx88_dvb,or51132,cx22702
cx88xx                 48032  2 cx88_dvb,cx8802
ir_common               7940  1 cx88xx
bttv                  146320  0
video_buf              18692  5 cx88_dvb,cx8802,video_buf_dvb,cx88xx,bttv
v4l2_common             6528  0
btcx_risc               5768  3 cx8802,cx88xx,bttv
tveeprom               13272  2 cx88xx,bttv
nvidia               3465724  12
video                  15364  0

I've a hunch the snapshots don't work with this card. I'll next try it 
with 2.6.11 and the 20050120 snapshot.
Regards
Sid.
-- 
Sid Boyce .... Hamradio G3VBV and Keen Flyer
=====ALMOST ALL LINUX USED HERE, Solaris 10 SPARC is just for play=====




More information about the linux-dvb mailing list