[linux-dvb] frontend driver problem with Nebula DigiTV card

Ryan Duffy dusteur at excite.com
Mon Mar 7 23:53:49 CET 2005



I've got a Nebula card which works under windows, and has worked under Linux in the past. Can anyone help me sort out the problem?

I'm using 2.6.11 with the 2.6.11-1 All patch from bytesex.org.

The failure seems to be when trying to register the nxt6000, with this error coming up when nxt6000 is modprobed with debug=1:
nxt6000: nxt6000_read error (reg: 0x73, ret: -5)

I get different ret values sometimes. Looking at the code, it seems maybe something to do with i2c, but I don't really know what i2c is, so I'm stuck!

The relevant syslog output is here:
Mar  7 22:19:02 raaar kernel: bttv: driver version 0.9.15 loaded
Mar  7 22:19:02 raaar kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar  7 22:19:02 raaar kernel: bttv: Bt8xx card found (0).
Mar  7 22:19:02 raaar kernel: ACPI: PCI interrupt 0000:00:09.0[A] -> GSI 11 (level, low) -> IRQ 11
Mar  7 22:19:02 raaar kernel: bttv0: Bt878 (rev 17) at 0000:00:09.0, irq: 11, latency: 32, mmio: 0xde000000
Mar  7 22:19:02 raaar kernel: bttv0: detected: Nebula Electronics DigiTV [card=104], PCI subsystem ID is 0071:0101
Mar  7 22:19:02 raaar kernel: bttv0: using: Nebula Electronics DigiTV [card=104,insmod option]
Mar  7 22:19:02 raaar kernel: bttv0: gpio: en=00000000, out=00000000 in=00ff00cf [init]
Mar  7 22:19:02 raaar kernel: bttv0: using tuner=-1
Mar  7 22:19:02 raaar kernel: bttv0: registered device video0
Mar  7 22:19:02 raaar kernel: bttv0: registered device vbi0
Mar  7 22:19:02 raaar kernel: bttv0: PLL: 28636363 => 35468950 . ok
Mar  7 22:19:03 raaar kernel: bttv0: add subdevice "dvb0"
Mar  7 22:19:03 raaar udev[7247]: creating device node '/dev/i2c-1'
Mar  7 22:19:03 raaar udev[7254]: creating device node '/dev/video0'
Mar  7 22:19:03 raaar udev[7261]: creating device node '/dev/vbi0'
Mar  7 22:19:17 raaar kernel: bt878: AUDIO driver version 0.0.0 loaded
Mar  7 22:19:17 raaar kernel: bt878: Bt878 AUDIO function found (0).
Mar  7 22:19:17 raaar kernel: ACPI: PCI interrupt 0000:00:09.1[A] -> GSI 11 (level, low) -> IRQ 11
Mar  7 22:19:17 raaar kernel: bt878(0): Bt878 (rev 17) at 00:09.1, irq: 11, latency: 32, memory: 0xde001000
Mar  7 22:19:25 raaar kernel: dvb_bt8xx: identified card0 as bttv0
Mar  7 22:19:25 raaar kernel: DVB: registering new adapter (bttv0).
Mar  7 22:19:25 raaar udev[7318]: configured rule in '/etc/udev/rules.d/udev.rules[60]' applied, 'dvb0.demux0' becomes 'dvb/adapter0/demux%n'
Mar  7 22:19:25 raaar udev[7318]: creating device node '/dev/dvb/adapter0/demux0'
Mar  7 22:19:25 raaar udev[7324]: configured rule in '/etc/udev/rules.d/udev.rules[59]' applied, 'dvb0.dvr0' becomes 'dvb/adapter0/dvr%n'
Mar  7 22:19:25 raaar udev[7324]: creating device node '/dev/dvb/adapter0/dvr0'
Mar  7 22:19:25 raaar udev[7328]: configured rule in '/etc/udev/rules.d/udev.rules[65]' applied, 'dvb0.net0' becomes 'dvb/adapter0/net%n'
Mar  7 22:19:25 raaar udev[7328]: creating device node '/dev/dvb/adapter0/net0'
Mar  7 22:19:25 raaar kernel: nxt6000: nxt6000_read error (reg: 0x73, ret: -5)
Mar  7 22:19:25 raaar kernel: dvb-bt8xx: A frontend driver was not found for device 109e/0878 subsystem 0071/0101


lsmod output is:
Module                  Size  Used by
dvb_bt8xx               8196  0
bt878                   8760  1 dvb_bt8xx
nxt6000                 6724  1 dvb_bt8xx
bttv                  148304  2 dvb_bt8xx,bt878
i2c_via                 3460  0
i2c_viapro              6608  0
tveeprom               11608  1 bttv
dvb_core               78376  1 dvb_bt8xx
mga                    57600  1
drm                    60372  2 mga
rtc                    10888  0
ehci_hcd               29064  0
video_buf              17796  1 bttv
firmware_class          7936  2 dvb_bt8xx,bttv
v4l2_common             4736  1 bttv
btcx_risc               3912  1 bttv
videodev                7488  1 bttv
snd_via82xx            22880  0
snd_ac97_codec         73848  1 snd_via82xx
snd_mpu401_uart         6336  1 snd_via82xx
snd_rawmidi            20576  1 snd_mpu401_uart
uhci_hcd               29712  0
usbcore               106744  3 ehci_hcd,uhci_hcd
amd_k7_agp              5900  0
via_agp                 7552  1
agpgart                28584  3 drm,amd_k7_agp,via_agp
via686a                17816  0
i2c_sensor              2944  1 via686a
i2c_isa                 1792  0
i2c_dev                 7936  0
i2c_algo_bit            8840  2 bttv,i2c_via
i2c_core               18512  10 dvb_bt8xx,nxt6000,bttv,i2c_viapro,tveeprom,via686a,i2c_sensor,i2c_isa,i2c_dev,i2c_algo_bit


If anyone can help, I will be very grateful - I really am stuck with this, and I know the card should be working but have no idea what I am doing wrong.

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!




More information about the linux-dvb mailing list