[linux-dvb] [PATCH] gcc 2.95, again

Johannes Stezenbach js at linuxtv.org
Sun Mar 20 13:06:18 CET 2005


Jouni Karvo wrote:
> The timeline for compilers would be simple - there is no need to
> support any other compiler than 2.95.3 as long as it is the
> recommended compiler version in the kernel documentation.

There are a number of architectures where no usable 2.95.x
compiler is available, e.g. x86-64. gcc-2.95.3 has been
release four years ago!

> Most people that compile kernels for their computers do not have
> insider information on kernel development so the kernel (including
> drivers) should compile with the instructions provided with the
> sources. 

Users without "insider information" should probably use the
default compiler that their distribution provides, which
is most likely gcc-3.3.x or gcc-3.4.x nowadays.

Johannes




More information about the linux-dvb mailing list