[linux-dvb] Typhoon Duo DVB-T Cardbus with saa7133 won't comeup

Hartmut Hackmann hartmut.hackmann at t-online.de
Thu Nov 3 00:12:03 CET 2005


Hi,

Looks like we haven't seen this card variant yet...
But Nico is right, please try to force the card type to 55 or 60
and see what happens. So:
modprobe saa7134 card=55
modprobe saa7134-dvb
You don't need a firmware file, the card should have an eeprom and
boot from this.
You might consider to update the drivers from linuxtv.org first,
please get the v4l-kernel and dvb-kernel CVS and follow the
instructions in the wiki. I just added some updates.

Good luck
    Hartmut

Nico Sabbi wrote:
> Martin Fay wrote:
> 
>> Hi Folks,
>>
>> first tx for all of yor great work!
>>
>> And now i have a problem
>> This card will not work in Suse or Ubuntu.
>>
>> Card:
>> Typhoon DVB-T Duo Digital/Analog 32bit Cardbus
>>
>> OS:
>> Ubuntu 5.10
>>
>>
>>
>> after i did a (root) modprobe saa7134-dvb here is the dmesg output:
>>
>> [4306459.391000] Linux video capture interface: v1.00
>> [4306459.438000] saa7130/34: v4l2 driver version 0.2.12 loaded
>> [4306459.447000] ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKA] -> 
>> GSI 11 (level, low) -> IRQ 11
>> [4306459.447000] saa7133[0]: quirk: PCIPCI_NATOMA
>> [4306459.447000] saa7133[0]: found at 0000:02:00.0, rev: 240, irq: 11, 
>> latency: 64, mmio: 0x10800000
>> [4306459.447000] saa7133[0]: subsystem: 4e42:0502, board: 
>> UNKNOWN/GENERIC [card=0,autodetected]
>>  
>>
> 
> ^^^ try to force saa7134 with card= the number assigned to Lifeview DUO
> 
>> [4306459.447000] saa7133[0]: board init: gpio is e010000
>> [4306459.448000] saa7133[0]: dsp access wait timeout [bit=WRR]
>> [4306459.448000] saa7133[0]: dsp access wait timeout [bit=WRR]
>> [4306459.561000] saa7133[0]: i2c eeprom 00: 42 4e 02 05 54 20 1c 00 43 
>> 43 a9 1c 55 d2 b2 92
>> [4306459.561000] saa7133[0]: i2c eeprom 10: 00 ff 22 0f ff 20 ff ff ff 
>> ff ff ff ff ff ff ff
>> [4306459.561000] saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 
>> ff 01 81 ff ff ff ff
>> [4306459.561000] saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff 
>> ff ff ff ff ff ff ff
>> [4306459.618000] saa7133[0]: registered device video0 [v4l2]
>> [4306459.660000] saa7133[0]: registered device vbi0
>>
>> looks like the driver is loadet but i cant access it also i am not so 
>> shure if the firmware file (dvb-fe-tda10046.fw 24 kb ???)
>> is exactly the right one.
>>
>> Can please annyone of you help me here?
>>



More information about the linux-dvb mailing list