[linux-dvb] [Newbie] Video / Audio dropouts with saa7134_dvb / DVB-t

Rainer Menzner Rainer.Menzner at web.de
Mon Nov 7 11:52:07 CET 2005


Hello all,

first of all, I'm a newbie WRT Linux-DVB, so if this is a known problem,
please excuse posting here ...

I have a hybrid Medion SAA7134 and I use DVB-t. The antenna etc. is OK.
Using Power Cinema under MS I receive good results.

Under Linux, also basically all works. However, I can't solve a few  problems:

1) The video signal shows arbitrary colored regions every once in a while (a few
seconds). Sometimes these corrupted regions are in a larger rectangle, sometimes
organized in a line, sometimes sprinkled over the whole image, there is no rule.

2) The audio is disturbed by dropouts and squeak, also every few seconds.

Aside from these problems, video and audio are perfect. The corruption appears also
when using tzap to record a TS directly to a file, so I assume it is not a
display / playback problem. Also, after such disturbances, the stream is good again, it
is not ripped off. It i

I have played with renicing dvb[0] or the tzap, but to no avail. The recording
program and the dvb process just use 10% of CPU time at most. I have no further
ideas and I really would appreciate recording under Linux.

Below is an excerpt from dmesg-output:

Linux version 2.6.13-15-default (geeko at buildhost) (gcc version 4.0.2 20050901 (prerelease) (SUSE Linux)) #1 Tue Sep 13 14:56:15 UTC 2005

[snip]

saa7134[0]: found at 0000:01:07.0, rev: 1, irq: 11, latency: 32, mmio: 0xf2015000
saa7134[0]: subsystem: 16be:0003, board: Medion 7134 [card=12,autodetected]
saa7134[0]: board init: gpio is 0
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.1 (8191 buckets, 65528 max) - 248 bytes per conntrack
saa7134[0]: i2c eeprom 00: be 16 03 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
saa7134[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 1f 02 51 96 2b
saa7134[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
saa7134[0] Board has DVB-T
saa7134[0] Tuner type is 63
 : chip found @ 0xc2 (saa7134[0])
tuner 2-0061: type set to 63 (Philips FMD1216ME MK3 Hybrid Tuner)
tda9885/6/7: chip found @ 0x86
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7134[0]: registered device radio0
hda: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
lp0: ECP mode

[snip]


I'm using firmware the latest firmaware dvb-ttpci-01.fw-261f.
I would appreciate any help on this.

Thanks and best regards,
-Rainer


______________________________________________________________
Verschicken Sie romantische, coole und witzige Bilder per SMS!
Jetzt bei WEB.DE FreeMail: http://f.web.de/?mc=021193




More information about the linux-dvb mailing list