[linux-dvb] Twinhan DST and 22khz tone switch not working

Luis Ochoa luis.m.ochoa at gmail.com
Tue Nov 8 22:42:19 CET 2005


Hi all,
I'm trying to figure this out.
My setup:

bttv: Bt8xx card found (1).
ACPI: PCI Interrupt 0000:02:05.0[A] -> Link [LNKF] -> GSI 5 (level,
low) -> IRQ 5
bttv1: Bt878 (rev 17) at 0000:02:05.0, irq: 5, latency: 32, mmio: 0xdb102000
bttv1: detected: ChainTech digitop DST-1000 DVB-S [card=113], PCI
subsystem ID is 270f:fc00
bttv1: using: Twinhan DST + clones [card=113,autodetected]
bttv1: gpio: en=00000000, out=00000000 in=00f423fe [init]
bttv1: using tuner=4
bttv1: add subdevice "dvb1"
....
DVB: registering new adapter (bttv1).
dst_get_device_id: Recognise [DST-03T]
DST type flags : 0x2 ts204 0x4 symdiv 0x10 firmware version = 2
dst_get_mac: MAC Address=[00:xx:xx:xx:xx:00]
DVB: registering frontend 1 (DST DVB-S)...

This card is connected to a 4x2 22khz tone switch (which works and
switches LNBs ok from a set-top-box).

I'm doing

$ FRONTEND=/dev/dvb/adapter1/frontend0 dvb-apps/test/set22k on
(I can actually hear the card clicking, etc)

and then

$dvbscan ....

but I always get the satellite for the LNB which is attached to the
"off" port of the switch (i.e. the switch is not switching).

Given that I see channels from both satellites from a set-top-box
connected to the same switch, is it:

-operator error? (is that the right way to use set22k, meaning, once I
issue the command the tone should stay ON, right?)
-is it driver problems?

what debug option should I turn on to help troubleshoot this?

Thanks a ton.

Luis.



More information about the linux-dvb mailing list