[linux-dvb] [Newbie] Video / Audio dropouts with saa7134_dvb/ DVB-t

Hartmut Hackmann hartmut.hackmann at t-online.de
Wed Nov 9 22:34:23 CET 2005


Hi, Rainer


(snip)
> 
> I downloaded the latest patches yesterday and recompiled the kernel, which
> did not solve the problem. But now I get a message about an invalid 
> firmware
> version. Here's the output of dmesg:
> 
> - Begin dmesg output 
> ----------------------------------------------------------
> Linux version 2.6.13-15-default (geeko at buildhost) (gcc version 4.0.2 
> 20050901 (prerelease) (SUSE Linux)) #1 Mon Nov 7 19:32:19 CET 2005
> BIOS-provided physical RAM map:
> 
> [snip]
> 
> ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[5]  
> MMIO=[f2014000-f20147ff]  Max Packet=[4096]
> saa7130/34: v4l2 driver version 0.2.14 loaded
> ACPI: PCI Interrupt Link [LNK4] enabled at IRQ 11
> ACPI: PCI Interrupt 0000:01:07.0[A] -> Link [LNK4] -> GSI 11 (level, 
> low) -> IRQ 11
> saa7134[0]: found at 0000:01:07.0, rev: 1, irq: 11, latency: 32, mmio: 
> 0xf2015000
> saa7134[0]: subsystem: 16be:0003, board: Medion 7134 [card=12,autodetected]
> saa7134[0]: board init: gpio is 0
> saa7134[0]: i2c eeprom 00: be 16 03 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
> saa7134[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 1f 02 51 96 2b
> saa7134[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
> saa7134[0] Board has DVB-T
> saa7134[0] Tuner type is 63
>  : chip found @ 0xc2 (saa7134[0])
> tuner 2-0061: type set to 63 (Philips FMD1216ME MK3 Hybrid Tuner)
> usb 2-2: new full speed USB device using ohci_hcd and address 2
> tda9885/6/7: chip found @ 0x86
> saa7134[0]: registered device video0 [v4l2]
> saa7134[0]: registered device vbi0
> saa7134[0]: registered device radio0
> hda: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
> 
You still have the old version of the driver running. As an indicator:
The new version dumps 128 bytes of the eeprom.
Please do the following:
- get CVS snapshots of v4l-kernel and dvb-kernel from www.linuxtv.org
- put them into the same directory
- cd v4l-kernel
- make merge-trees
- make
- make install (as root)
> 
> tda1004x: found firmware revision ff -- invalid
> tda1004x: booting from eeprom
> tda1004x: found firmware revision 26 -- ok
> - End dmesg output 
> ---------------------------------------------------------
> 
> Does this mean the wrong firmware is loaded? My link in /lib/firmware 
> points to
> dvb-ttpci-01.fw-261f, which is the latest version.
> 
The messages are normal for the old version of tda1004x.ko. This card
doesn't need a firmware file.
A last hint: In the version with the DMA bug corrected, the parameters
conerning the ts have no meaning.

Best regards
    Hartmut



More information about the linux-dvb mailing list