[linux-dvb] Compro Dvb-t300 problems

Hartmut Hackmann hartmut.hackmann at t-online.de
Thu Nov 17 00:25:13 CET 2005


Hi,

L C wrote:
>  Hi, I followed the guide on the wiki to try and get this card working. 
> I have appeard to make the kernel modules needed, though when getting to 
> the modeprobe part I get this error
>  
> sudo modprobe saa7134 oss=1 card=70
> FATAL: Error inserting saa7134 
> (/lib/modules/2.6.14-ck1/kernel/drivers/media/video/saa7134/saa7134.ko): 
> Unknown symbol in module, or unknown parameter (see dmesg)
> 
> and the dmesg error is as follows
> 
> 4313200.387000] saa7134_dvb: disagrees about version of symbol 
> saa7134_ts_register
> [4313200.387000] saa7134_dvb: Unknown symbol saa7134_ts_register
> [4313200.387000] saa7134_dvb: disagrees about version of symbol 
> saa7134_i2c_call_clients
> [4313200.387000] saa7134_dvb: Unknown symbol saa7134_i2c_call_clients
> [4313200.387000] saa7134_dvb: disagrees about version of symbol 
> saa7134_ts_unregister
> [4313200.387000] saa7134_dvb: Unknown symbol saa7134_ts_unregister
> [4315481.817000] saa7134: Unknown symbol ir_codes_pinnacle
> [4315520.156000] saa7134: Unknown symbol ir_codes_pinnacle
> [4315543.873000] saa7134: Unknown symbol ir_codes_pinnacle
> [4315543.874000] saa7134_dvb: Unknown symbol saa7134_ts_register
> [4315543.874000] saa7134_dvb: Unknown symbol saa7134_ts_qops
> [4315543.874000] saa7134_dvb: Unknown symbol saa7134_i2c_call_clients
> [4315543.874000] saa7134_dvb: Unknown symbol saa7134_ts_unregister
> [4317777.529000] saa7134: Unknown symbol ir_codes_pinnacle
> [4318476.861000] saa7134: Unknown symbol ir_codes_pinnacle
> 
> I did at one stage have the saa7134 module loaded, but got a simillar 
> error trying to modprobe the saa7134-dvb. So I rmmod'ed all the modules, 
> pertaining to dvb cards, and then re modprobed them and then I got the 
> error posted
> 
> I'm trying to do this on Ubuntu Breezy running a vanilla 2.6.14 kernel 
> with +ck1 patch set
> 
> This is using the latest v4l from the cvs using the cvs guide at 
> linuxtv.org
> Would this just be because the kernel isn't the right one and I have to 
> use a snapshot of the cvs or something??
> 
> Thanks in advance
> 

I haven't tried 2.6.14 yet, but the errors sound like you have a version
mismatch between saa7134 and saa7134-dvb. Did you download dvb-kernel as
well and did you do the "make merge-trees" before the "make"?
Did you run the "make install" being root? Did the compile run smoothly
and generate the dvb modules as well? i.e. saa7134-dvb.ko, video-buf-dvb.ko,
tda1004x.ko. If yes, please check whether some of the new kernel modules
occur twice.

Best regards
    Hartmut



More information about the linux-dvb mailing list