[linux-dvb] Pinnacle 310i

Rainer Schubert lintv at dl6hbo.inka.de
Thu Nov 17 16:38:52 CET 2005


On Thu, 17 Nov 2005, bardinov at utt.fr wrote:

Hi Vince, Hartmut and the list,

[...]
> Hi,
>
> I'm trying the dvb part with 310i.
> I do modprobe saa7134 card=81 and
> modprobe saa7134-dvb
> All seems to be good here.

OK.

> But after I ran "dvbscan -n -o zap -p /usr/local/share/dvb/scan/dvb-t/fr-Reims >
> channels.conf" I get this:
>
> scanning /usr/local/share/dvb/scan/dvb-t/fr-Reims
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> initial transponder 562000000 0 2 9 3 1 0 0
> initial transponder 554000000 0 2 9 3 1 0 0
> initial transponder 602000000 0 2 9 3 1 0 0
> initial transponder 578000000 0 2 9 3 1 0 0
> initial transponder 666000000 0 2 9 3 1 0 0
> initial transponder 642000000 0 2 9 3 1 0 0
>>>> tune to:
> 562000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_32:HIERARCHY_NONE
> __tune_to_transponder:1478: ERROR: FE_READ_STATUS failed: 5 Input/output error
[...]

> This is the dmesg:
>
> tda1004x: setting up plls for 48MHz sampling clock
> tda1004x: found firmware revision 0 -- invalid
> tda1004x: booting from eeprom
> tda1004x: found firmware revision 0 -- invalid
> tda1004x: firmware upload failed

The above line says it all: firmware upload failed

The card can't work without the corresponding firmware.

> tda1004x: pll set failed
> tda1004x: pll set failed

That's why pll set failed !
[...]
>
> I do ./get_dvb_firmware tda10046 and then copy the file "dvb-fe-tda10046.fw" to
> /usr/local/lib/firmware/
> But I didn't see any changes.
>
> Could you tell me where is my mistake?

As Hartmut has posted, it's not your fault (mistake), but the 310i
card is so different from the 300i that it needs a special driver
just for this very card.

> thanks
> vince

Regards,
Rainer
-- 
Rainer Schubert - Linux TV User
Amateur Radio Call DL6HBO



More information about the linux-dvb mailing list