[linux-dvb] cx24123 receives wrong tone [heur][sls]

Giuliano A. Montecarlo gggiuly at googlemail.com
Mon Nov 21 02:20:36 CET 2005


Steve Toth wrote:

> Giuliano A. Montecarlo wrote:
>
>> Steve Toth wrote:
>>
>>  
>>
>>>>  
>>>>
>>>>      
>>>>
>>>>>> Is this broken on my maschine? And is there a possibility to fix it?
>>>>>>
>>>>>>                   
>>>>>
>>>>> And you say this used to work, but does not now? - It was broken 
>>>>> recently?
>>>>>
>>>>> Steve
>>>>>
>>>>>
>>>>>             
>>>>
>>>> Yes, it's broken recently, after installing a clean cvs.
>>>>
>>>>         
>>>
>>> Nothing has changed in the driver, it's an app issue. Try testing 
>>> with szap and see what happens.
>>>
>>>     
>>
>
>> But mplayer and xine will fail to play anything from adapter0/dvr0.
>>   
>
> what does /var/log/messages look like? Are you seeing the SET_TONE 
> default CASE error?
>
> I was using mplayer a few days ago and this was working just fine, no 
> default CASE = 2 messages. szap also works for me.
>
> Have you tried dvbtune?
>
> I don't see how the driver can be wrong, unless either the app is 
> wrong or the calling code is passing bad values. Can you go back to a 
> previous build and validate the tools are good, just to be sure it's a 
> driver/kernel thing?
>
> Steve
>
>
>
No, I don't have a previous build anymore. I've recompiled 
kernel+dvb+v4l, with the hope that it helps, but still still the "CASE 
reached default with tone=2".

# ./dvbtune -f 12551500 -p v -s 22000000
Using DVB card "Conexant CX24123/CX24109"
tuning DVB-S to L-Band:0, Pol:V Srate=525163520, 22kHz=off
ERROR setting tone
: Operation not supported
polling....
Getting frontend event
FE_STATUS:
polling....
(...)
polling....




More information about the linux-dvb mailing list