[linux-dvb] Compro Videomate DVB-T300

Ian McKenzie ianmck15 at hotmail.com
Thu Oct 6 12:57:38 CEST 2005


Hi, I have a Videomate DVB-T 300 card and use Slackware 10.2 kernel 2.6.13.
The card works fine in Windoze (dual-booting) but i would like to get it 
going in linux. This should be possible as others on this mailing list seem 
to have done so.
After reading a lot of docs and installing various things most things seem 
to be in place but still no joy.
Here are some readouts: lsmod

Module                  Size  Used by
ipv6                  225600  8
snd_pcm_oss            46240  0
snd_mixer_oss          15872  1 snd_pcm_oss
uhci_hcd               29584  0
nvidia_agp              5916  1
i2c_nforce2             5888  0
joydev                  8000  0
ohci_hcd               18436  0
ehci_hcd               29704  0
sata_nv                 6276  0
libata                 39940  1 sata_nv
shpchp                 91364  0
snd_emu10k1            99460  0
snd_rawmidi            19232  1 snd_emu10k1
snd_seq_device          6924  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         75388  1 snd_emu10k1
snd_pcm                75016  3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_timer              19716  2 snd_emu10k1,snd_pcm
snd_page_alloc          7556  2 snd_emu10k1,snd_pcm
snd_util_mem            3328  1 snd_emu10k1
snd_hwdep               6944  1 snd_emu10k1
snd                    45572  9 
snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmid
i,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer,snd_hwdep
emu10k1_gp              2816  0
gameport               11144  2 emu10k1_gp
8139too                22016  0
mii                     4608  1 8139too
nvidia               3703688  12
ext3                  122504  2
jbd                    48024  1 ext3
nls_iso8859_1           3968  1
nls_cp437               5632  1
vfat                   10368  1
fat                    44828  1 vfat
nls_utf8                1792  2
ntfs                  182672  2
agpgart                28616  2 nvidia_agp,nvidia
dvb_ttpci              86332  0
l64781                  6660  1 dvb_ttpci
saa7146_vv             42880  1 dvb_ttpci
saa7146                14600  2 dvb_ttpci,saa7146_vv
ves1820                 5252  1 dvb_ttpci
stv0299                10248  1 dvb_ttpci
tda8083                 5252  1 dvb_ttpci
stv0297                 7424  1 dvb_ttpci
sp8870                  6796  1 dvb_ttpci
ves1x93                 6148  1 dvb_ttpci
ttpci_eeprom            2304  1 dvb_ttpci
saa7134_dvb             6788  0
mt352                   6148  1 saa7134_dvb
saa7134               105044  1 saa7134_dvb
v4l2_common             4608  2 saa7146_vv,saa7134
v4l1_compat            13060  2 saa7146_vv,saa7134
soundcore               6880  2 snd,saa7134
ir_common               6916  1 saa7134
videodev                7168  2 saa7146_vv,saa7134
evdev                   7296  0
video_buf_dvb           4356  1 saa7134_dvb
dvb_core               71848  2 dvb_ttpci,video_buf_dvb
video_buf              16900  4 saa7146_vv,saa7134_dvb,saa7134,video_buf_dvb
tda1004x               13316  1 saa7134_dvb
firmware_class          7424  4 dvb_ttpci,sp8870,saa7134_dvb,tda1004x
i2c_core               16656  14 
i2c_nforce2,dvb_ttpci,l64781,ves1820,stv0299,td                              
                                               
a8083,stv0297,sp8870,ves1x93,ttpci_eeprom,saa7134_dvb,mt352,saa7134,tda1004x
psmouse                29956  0
reiserfs              223216  4
root at comp2:~#

relevant section of: dmesg

input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
Linux video capture interface: v1.00
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7130/34: snapshot date 2005-08-01
ACPI: PCI Interrupt Link [LNK2] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:01:09.0[A] -> Link [LNK2] -> GSI 5 (level, low) -> 
IRQ 5
saa7134[0]: found at 0000:01:09.0, rev: 1, irq: 5, latency: 32, mmio: 
0xe7000000
saa7134[0]: subsystem: 185b:c900, board: UNKNOWN/GENERIC 
[card=0,autodetected]
saa7134[0]: board init: gpio is 843f00
saa7134[0]: i2c eeprom 00: 5b 18 00 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7134[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7134[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 87 ff ff ff ff
saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7134[0]: registered device video0 [v4l2]
saa7134[0]: registered device vbi0
saa7146: register extension 'dvb'.
Linux agpgart interface v0.101 (c) Dave Jones

lspci:

01:09.0 Multimedia controller: Philips Semiconductors SAA7134 Video 
Broadcast Decoder (rev 01)

In /lib/firmware there is:  dvb-fe-tda10046.fw and  dvb-ttpci-01.fw-261f  
and  tda10046.bin

In /usr/lib/hotplug/firmware there is the same 3 firmware files.
I hacked the /etc/rc.d/rc.modules script to get the modules to load on boot 
as is shown by the lsmod readout.
In /sys/class/firmware there is just the timeout file.
I would like to use kaffeine-0.7.1 to watch tv as this has a DVB facility 
and i am having troubles with mysql that makes mythtv a challenge at this 
time.
kaffeine does not recognize the DVB-T300.
When i do  "modprobe saa7134 oss=1"
- do "modprobe saa7134-dvb"
as suggested by Hartmut Hackmann nothing happens.
Could anyone suggest where i am going wrong?
Thanks, Ian.





More information about the linux-dvb mailing list