[linux-dvb] Leadtek WinFast DTV1000-T problems

Shirley, David David.Shirley at team.telstra.com
Tue Oct 11 07:56:36 CEST 2005


Hi All,

I purchased one of these recently; it has LR6550 written on the back of
it.

Here is what I know about it, cx2388 chipset, cx22702 remod, Thompson
7579 tuner - the card it self has RF IN + BYPASS, analogue IN + Svideo
IN, + remote control.

I have modded cx88-cards.c and some other files to add the PCI ID's and
the card is detected.

I can also receive a signal and capture picture using dvbstream |
mplayer.

HOWEVER the problem I have is tzap only gets 0x0031 (+/- 2) for the
signal strength. Also the SNR is usually 0xffff when LOCKED.

Also when I unplug the antenna or fake a bad signal (ie unplug it a
little bit + wiggle) then the signal actually INCREASES to something
like 0x0050 (always 0x00xx thou)

Anyway this "low signal strength" causes Mythtv to ignore the card I
think.

Has anyone got any ideas/experience with this to help me out.

Linux 2.6.14-rc3 if you are interested.

Here is the tzap output using latest v4l-kernel + dvb-kernel cvs.

tzap -c /usr/share/doc/dvb-utils/examples/channels.conf-dvbt-australia
"Ten HD"
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 219500000 Hz
video pid 0x0202, audio pid 0x0000
status 00 | signal 0030 | snr 8000 | ber 00003fff | unc 00000000 | 
status 1f | signal 0030 | snr ffff | ber 00000000 | unc 00000000 |
FE_HAS_LOCK
status 1f | signal 0030 | snr ffff | ber 00000000 | unc 00000000 |
FE_HAS_LOCK
status 1f | signal 0030 | snr ffff | ber 00000000 | unc 00000000 |
FE_HAS_LOCK

As you can see from below, Michael Krufky has added this card into the
cx88-cards.c in CVS.

Cheers
Dave



-----Original Message-----
From: Michael Krufky [mailto:mkrufky at linuxtv.org] 
Sent: Tuesday, 11 October 2005 3:34 PM
To: Linux and Kernel Video
Cc: Shirley, David
Subject: Re: Leadtek WinFast DTV1000-T

Shirley, David wrote:
> Hi Michael,
> 
> Sure thing, first here is my tzap:
[snip]
> Here is the patch:

Thank you.  I have added your patch into v4l-kernel cvs.  "WinFast 
DTV1000-T" is now cx88 card #35.  Please grab and install a copy of 
v4l-kernel cvs and confirm that it works properly.

http://linuxtv.org/v4lwiki/index.php/How_to_build_from_CVS

If you have any more patches to submit, please work from v4l-kernel cvs.

About the bug that you are reporting about signal strength / snr 
etc.....  The linuxdvb mailing list (subscriber-only: 
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb) is more 
appropriate place to ask about it.  It might be a good idea for you to 
try using the cx22702 frontend driver in dvb-kernel cvs before writing 
to that list.  You can get combined cvs trees installed using most 
recent v4l cx88 driver + most recent dvb cx22702 driver by using the 
merge-trees make option, explained in the HOWTO above.

Good Luck,
Michael Krufky



More information about the linux-dvb mailing list