[linux-dvb] Compro DVB-T200 - saa7134-dvb not loading

James Sheridan james at pixelix.co.uk
Tue Oct 18 21:41:26 CEST 2005


On Tue, 18 Oct 2005, James Sheridan wrote:

> I have removed my sources and followed your commands, but unfortunately I 
> still recieve the same dvb_dmx_init failed error. :(
> Thanks for your quick response - any other ideas gratefully recieved!

I have now upgraded to 2.6.13.4, and followed the instructions given at 
http://www.linuxtv.org/v4lwiki/index.php/How_to_build_from_CVS - and I am 
still unable to use my card. I still receive the following in dmesg:

saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt 0000:01:04.0[A] -> GSI 18 (level, low) -> IRQ 169
saa7130[0]: found at 0000:01:04.0, rev: 1, irq: 169, latency: 32, mmio: 0xf80100 00
saa7130[0]: subsystem: 185b:c901, board: Compro Videomate DVB-T200 [card=71,auto detected]
saa7130[0]: board init: gpio is 843f00
saa7130[0]: registered input device for IR
saa7130[0]: i2c eeprom 00: 5b 18 01 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7130[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 20: 01 40 01 03 03 ff 03 01 08 ff 00 88 ff ff ff ff
saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 40: ff d0 00 c2 86 10 ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
saa7130[0]: i2c eeprom 60: 30 26 ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7130[0]: registered device video0 [v4l2]
saa7130[0]: registered device vbi0
DVB: registering new adapter (saa7130[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
saa7130[0]: dvb_dmx_init failed (errno = -12)

Attempting to use a DVB related application results in:
(Using 'scan' from the DVB CVS repository)
"./scan dvb-t/uk-SandyHeath | tee mychannels.conf"
scanning dvb-t/uk-SandyHeath
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
main:1819: FATAL: failed to open '/dev/dvb/adapter0/frontend0': 19 No such device

I'd really like to see this card working - any tips would be gratefully 
received.

If you need any further information, please drop me a mail.

Thanks in advance,

-- 
James.



More information about the linux-dvb mailing list