[linux-dvb] Asus MyCinema P7131 Dual

Hartmut Hackmann hartmut.hackmann at t-online.de
Wed Oct 19 22:38:58 CEST 2005


Hi,

This card is not supported yet, sorry. It should be possible to get
the analog part working with recent CVS. But there is no support for
DVB-T with tda8275a and tda10046 yet. The tda8275a is very different
from the non-a version. I started working on this, please be patient.


Stay tuned
    Hartmut

JJL wrote:
> Hello,
> 
> I have this card and I'm trying to use it with Linux.
> Following this advice[1] I've get the cvs for dvb-kernel and copied
> the Lifeview FlyDVB-T Duo definition to a new card in saa7134-cards.c
> and saa7134.h (card #75)
> then make, make install and modprobe saa7134_dvb : the card is seen
> but no dvb-t.
> Here's dmesg output :
> saa7130/34: v4l2 driver version 0.2.14 loaded
> bus pci: add driver saa7134
> pci: Matched Device 0000:00:14.0 with Driver saa7134
> ACPI: PCI Interrupt 0000:00:14.0[A] -> Link [LNKB] -> GSI 5 (level,
> low) -> IRQ 5
> saa7133[0]: found at 0000:00:14.0, rev: 208, irq: 5, latency: 32,
> mmio: 0xde003000
> saa7133[0]: subsystem: 1043:4862, board: AsusTek My Cinema P7131 Dual
> [card=75,autodetected]
> saa7133[0]: board init: gpio is 0
> DEV: registering device: ID = 'i2c-0'
> PM: Adding info for No Bus:i2c-0
> saa7133[0]: i2c eeprom 00: 43 10 62 48 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
> saa7133[0]: i2c eeprom 10: 00 01 20 00 ff 20 ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 03 08 ff 00 d6 ff ff ff ff
> saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 00 ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
> bus i2c: add driver tuner
> saa7133[0]: registered device video0 [v4l2]
> saa7133[0]: registered device vbi0
> bound device '0000:00:14.0' to driver 'saa7134'
> pci: Bound Device 0000:00:14.0 to Driver saa7134
> saa7133[0]: Huh? unknown DVB card?
> saa7133[0]: frontend initialization failed
> 
> It seems to be a init problem in saa7134-dvb.c but I have no idea of
> what I can do at this point :(
> (doing the same as for SAA7134_BOARD_FLYDVBTDUO did not solve, still
> the message frontend initialization failed)
> 
> Can anybody help me ?
> 
> Thanks in advance
> Best regards
> JJL
> 
> lspci -v
> 0000:00:14.0 Multimedia controller: Philips Semiconductors SAA7133
> Audio+video broadcast decoder (rev d0)
>         Subsystem: Asustek Computer, Inc.: Unknown device 4862
>         Flags: bus master, medium devsel, latency 32, IRQ 5
>         Memory at de003000 (32-bit, non-prefetchable) [size=2K]
>         Capabilities: [40] Power Management version 2
> lspci -v -n
> 0000:00:14.0 0480: 1131:7133 (rev d0)
>         Subsystem: 1043:4862
>         Flags: bus master, medium devsel, latency 32, IRQ 5
>         Memory at de003000 (32-bit, non-prefetchable) [size=2K]
>         Capabilities: [40] Power Management version 2
> 
> 
> [1] http://www.linuxtv.org/pipermail/linux-dvb/2005-September/004780.html
> 
> 
> --
> http://kubuntu.free.fr
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 



More information about the linux-dvb mailing list