[linux-dvb] T200 Remote Oddities

Kayne Richens kaynojunk at westnet.com.au
Sun Oct 23 22:41:19 CEST 2005


Ben Griffiths wrote:

>Hi,
>
>I have a Compro T200 
>
I have the compro t300 - not sure how much difference there is...

>which is working great with TV but the remote is 
>producing strange phantom button presses. I have it set up with lirc and then 
>I've been testing it using irw from the lirc package. So when I press the up 
>button UP is printed out, yet I get extra lines in the output showing a 
>button has been pressed though I haven't. 
>
... but i get this problem too:

# irw
0000000000010160 00 OK linux-input-layer
0000000000010067 00 UP linux-input-layer
0000000000010067 00 UP linux-input-layer
0000000000010067 00 UP linux-input-layer
0000000000010160 00 OK linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
000000000001008b 00 MENU linux-input-layer
000000000001008b 00 MENU linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer
0000000000010080 00 STOP linux-input-layer

the UPs and OKs at the start were fine, and after that i just kept 
pressing STOP, but as you can see, there are some MENUs in amongst there 
that i never pressed.

>For example, I tried the following 
>sequence on the remote,
>UP, UP, UP, OK, UP UP UP, OK
>But the output produced was,
>ben at marty:~> irw
>0000000000010067 00 UP linux-input-layer
>0000000000010067 00 UP linux-input-layer
>0000000000010067 00 UP linux-input-layer
>0000000000010160 00 OK linux-input-layer
>0000000000010067 00 UP linux-input-layer
>0000000000010067 00 UP linux-input-layer
>0000000000010067 00 UP linux-input-layer
>0000000000010067 00 UP linux-input-layer  <-- Why did this appear
>0000000000010160 00 OK linux-input-layer
>That extra line appeared when I pressed the OK button. If I just let it sit 
>there nothing happens. Unfortunately I can't see a pattern as to when it 
>occurs.
>
>Has anyone else had anything like this.
>
>Thanks,
>Ben
>
>_______________________________________________
>linux-dvb mailing list
>linux-dvb at linuxtv.org
>http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>
>  
>




More information about the linux-dvb mailing list