[linux-dvb] Garbled video/audio from TwinHan DVB-C card

Manu Abraham abraham.manu at gmail.com
Mon Oct 31 10:11:49 CET 2005


Per Dalén wrote:

> Manu Abraham wrote:
>
>> Svein Olav Bjerkeset wrote:
>>
>>> Hi,
>>>
>>> After installing my new DVB-C card (TwinHan Cab-CI), compiling a custom
>>> 2.6.14 kernel with DVB support, I get only garbled audio/video from the
>>> driver. I have tested on a FTA channel and I have no problem with this
>>> channel when using WinXP (on the same machine).
>>>
>>> I have compiled dvb-apps from CVS and channel scanning and tuning 
>>> works fine.
>>>
>>> An example of the garbled output can be found on the following URL:
>>> http://bjerkeset.com/DVB/twinhan.mpeg
>>> (generated with: dvbstream -o -n 60 -ps -c 0 -qam 64 -v 517 -a 660  >
>>> twinhan.mpeg)
>>>
>>> The output looks similar when played directly with mplayer or xine, e.g
>>> # mplayer - < /dev/dvb/adapter0/dvr0
>>> # xine http://bjerkeset.com/DVB/twinhan.mpeg
>>>
>>> Output from dmesg:
>>> =====================================
>>> Linux video capture interface: v1.00
>>> bttv: driver version 0.9.16 loaded
>>> bttv: using 8 buffers with 2080k (520 pages) each for capture
>>> bttv: Bt8xx card found (0).
>>> bttv0: Bt878 (rev 17) at 0000:00:06.0, irq: 10, latency: 64, mmio: 
>>> 0xdddfe000
>>> bttv0: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID is
>>> 1822:0001
>>> bttv0: using: Twinhan DST + clones [card=113,insmod option]
>>> bttv0: gpio: en=00000000, out=00000000 in=00fb0cfd [init]
>>> bttv0: using tuner=4
>>> bttv0: add subdevice "dvb0"
>>> bt878: AUDIO driver version 0.0.0 loaded
>>> bt878: Bt878 AUDIO function found (0).
>>> bt878(0): Bt878 (rev 17) at 00:06.1, irq: 10, latency: 64, memory: 
>>> 0xdddff000
>>> DVB: registering new adapter (bttv0).
>>> dst_get_device_id: Recognise [DCT-CI]
>>>
>>> DST type flags : 0x1 newtuner 0x2 ts204 0x8 firmware version = 1 0x10
>>> firmware version = 2
>>> dst_get_mac: MAC Address=[00:08:ca:16:15:00]
>>> dst_ca_attach: registering DST-CA device
>>> DVB: registering frontend 0 (DST DVB-C)...
>>>
>>>
>>> Does anyone know what can be the cause of a problem like this? I 
>>> found a
>>> thread in the mailinglist archive that suggests it should be 
>>> possible to
>>> get this card working:
>>> http://www.linuxtv.org/pipermail/linux-dvb/2005-September/004730.html
>>>
>>>  
>>>
>> You can check this out whether it helps, for the time being ..
>>
>> http://www.linuxtv.org/pipermail/linux-dvb/2005-September/004866.html
>>
>> Manu
>>
>
> I have the same card as You and can run it without any problems with 
> the latest cvs version + the fix Manu pointed out.
> I'm using 2.6.14-rc1 for the moment (will test it with 2.6.14 tonight).
>
> Manu, do You have any solution for how one could detect which kind of 
> Twinhand VP-20XX card it is?
>

The 2031 has a feature to identify itself. I have requested the vendor 
to provide some info on that. Not yet received the feedback from them 
for the 20xx. For the newer DVB-T cards, there was a similar fix needed. 
It would be something similar. I did not want to do a trial and error 
method, but preferred to wait for information.

Manu




More information about the linux-dvb mailing list