[linux-dvb] Pinnacle 300i working

Michael Krufky mkrufky at linuxtv.org
Sat Sep 17 15:25:04 CEST 2005


tim0m1a wrote:
> [...]
> 
>> What a sad story.....  This is a v4l issue, cc added.
>>
>> I appreciate that you have gotten your card working, but this isn't  
>> really a solution to the problem.  In fact, seeing something like 
>> this  makes me want to fix the problem the right way, but my hands are 
>> tied on  this, as I do not know the cause of the problem, or exactly 
>> what patches  you had to revert in order to fix it, nor do I have the 
>> hardware to test  this on.
>>
>> I can take a closer look at this over the weekend, but it would be a  
>> great service if you could actually go through the cvs and figure out  
>> exactly what patch breaks support for your card.  If you cannot do 
>> that,  then if you could at least try to get the absolute very latest 
>> cvs where  your card still works.... For example:
>>
>> You can do cvs checkout -D {date}  to specify that cvs should 
>> checkout  all cvs code where commits are no later than {date} ... If 
>> you can  identify the FIRST date where cvs is broken for your card, 
>> that can help  us to identify exactly which patch is the culprit here.
>>
>> The RIGHT thing to do would be to use this information to apply a new  
>> patch to cvs that will restore full functionality of your board, 
>> without  causing any other regressions.
> 
> [...]
> 
> So far so good...
> 
> I installed different CVS-Versions now. Since I installed 2005/07/14, 
> the  Pinnacle 300i does not run anymore. The following files were 
> changed in  the 2005/07/14-Snapshot:

Ah!  On July 15th, we removed all of the dvb frontend code from 
video4linux cvs.  Since then, I've created tree-merging scripts that 
allow you to download the latest copy of both cvs trees, and build 
complete drivers from the merged tree.

MT352 is among the drivers that have been removed from video4linux cvs. 
  I take it that you have not yet tried the tree-merging scripts on the 
latest cvs.  Please try the method outlined in this howto:

http://linuxtv.org/v4lwiki/index.php/How_to_build_from_CVS

This should fix the problem for you.  If so, please change your 
gentoo-wiki-entry to reflect this method.

-- 
Michael Krufky



More information about the linux-dvb mailing list