[linux-dvb] does Linux-2.6.13 support CableStar 2 PCI?

Patrick Boettcher patrick.boettcher at desy.de
Sun Sep 18 23:14:47 CEST 2005


Hi,

first try Anssi suggestion. I think it should help.

On Sun, 18 Sep 2005, Innocenti Maresin wrote:
> As far as I know, CableStar 2 _officially_ is not supported yet by Linux.
> But there is a "modified dvb-kernel-snapshot" by Patrick Boettcher
> ( see http://www.linuxtv.org/pipermail/linux-dvb/2005-July/003215.html ,
>  http://www.wi-bw.tfh-wildau.de/~pboettch/home/index.php?site=cable4pc )
> that give a CableStar 2 support on the base of b2c2-flexcop driver.
>
> One month ago I got Linux-2.6.13-rc6 from kernel.org

You can use dvb-kernel CVS now. Currently there is a temporary 
stv0297-driver which works with the CableStar2.

> linux-2.6.13-rc6/Documentation/dvb/README.flexcop states that
>   - add support for CableStar (stv0297 Microtune 203x/ALPS)
>     (almost done, incompatibilities with the Nexus-CA)
> , but I think it does not mean CableStar _2_ PCI (so named budget) cards.

There is no CableStar (one), but only a CableStar2. I sometime forget to 
write the 2... Sorry for the confusion.

> Unfortunally, Patrick Boettcher gives a tarball of sources,
> not *patch* to [mainstream] drivers.

Try current dvb-kernel CVS. As my website says, there is no need anymore 
to use the modified dvb-kernel snapshot.

best regards,
Patrick.

--
   Mail: patrick.boettcher at desy.de
   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/



More information about the linux-dvb mailing list