[linux-dvb] Re: Artec DVB T1 cold start problem

Patrick Boettcher patrick.boettcher at desy.de
Fri Sep 30 09:13:42 CEST 2005


On Thu, 29 Sep 2005, Damiano ALBANI wrote:

> --- Patrick Boettcher wrote :
>
>> which kernel are you using? If you are able to,
>> please
>> update to 2.6.13
>> and use  the instructions from here:
>>
> http://www.linuxtv.org/wiki/index.php/Artec_T1_USB_TV_Box
>
> I am using kernel 2.6.10 (Ubuntu). I followed the
> instructions, but applied to 2.6.10. That is, I
> uncommented line line 269
> (<http://lxr.linux.no/source/drivers/media/dvb/dibusb/dvb-dibusb.h?v=2.6.10#L269>).

This driver is very old and you are using a "new" device. If possible go 
to 2.6.13 and try the HOWTO again.

> And then it works OK (sound/video in MPlayer for
> example).
> What is even stranger is that hotplug is unable to
> upload the firmware to the device more than one time
> -- if I unplug and replug the device for example. It
> says 'did not find a valid firmware file' but I know
> this is not the origin of the error as the file is
> here. I have to reload hotplug through its init.d
> script to finally get the firmware uploaded.
>
> Do you have an idea of what's going on ?
> Is it possible to backport the latest DVB kernel to
> 2.6.10 ?

You can use dvb-kernel from 30 May 2005. It should work with your kernel 
and your card (after uncommenting DVB_USB_DIBUSB_MB_FAULTY_USB_IDs in 
dibusb-mb.c).

HTH,
Patrick.

--
   Mail: patrick.boettcher at desy.de
   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/



More information about the linux-dvb mailing list