[linux-dvb] Compro DVB-T300 remote

Mark Callaghan mark at lostcow.com
Wed Apr 5 02:57:55 CEST 2006


James, Hartmut,

>Hi Mark & Hartmut,
>

>Hartmut wrote:
>>Hi, Mark
>>
>>
>>Mark Callaghan wrote:
>>> I have done a mythdora install, with some problems with the remote on 
>>> the Compro DVB-T300. The card is not registering as an input device, as 
>>> it did with a previous install (earlier kernel, dvb module build from 
>>> cvs). Relevant parts of dmesg (from a cold boot) below. Two items of 
>>> interest:
>>>  
>>>     input: device saa7134 IR (Compro Videomate DV is statically 
>>> allocated, will not register
>>>     Please convert to input_allocate_device() or contact 
>>> dtor_core at ameritech.net <mailto:dtor_core at ameritech.net>
>>>     saa7134[0]: registered input device for IR
>>> and
>>>  
>>>     tuner 2-0061: i2c i/o error: rc == -5 (should be 4)
>>> I don't know if this "tuner 2..." line means anything or not.
>>>  
>>> Has there been some change in the kernel that saa7134 doesn't know 
>>> about? Is there a possible build problem with mythdora?
>>>  
>>I can't tell about the remote control since i don't have such a card,
>>only a similar one without remote.
>>The message concerning the tuner can occur if a tv application tries
>>to access the tuner while the card is in DVB-T mode. This can not work,
>>there is only one tuner for both modes.
>>

>>Best regards
>>    Hartmut
>

>I have seen a very similar dmesg error message that Mark has seen:
>tuner 2-0061: i2c i/o error: rc == -5 (should be 4)
>but only ever with the second of my two cards. It does not happen consistently and has not happened in my most recent boot,
> so I can't confirm that it is identical. I am confident about the "i2c i/o error: rc == -5 (should be 4)" bit but not about the "tuner 2-0061:" bit.
>

>Mark, have you ever seen a problem with your remote control like the I described in this post:
> http://www.linuxtv.org/pipermail/linux-dvb/2006-March/008705.html
>

>Regards,
>James.

The old Compro refuses to lie down & die, doesn't it!

I'll contact dtor_core at ameritech.net as suggested in the dmesg.

Hartmut, Thanks for the explanation of the tuner error.

James, I had my remote going for a short time, and I was concentrating on other things - I didn't notice the repeated button. I don't know if I had the problem or not. James - what kernel are you using, and are you building your own dvb modules or did they come with the kernel?

Cheers,
Mark

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060405/f018055c/attachment.htm


More information about the linux-dvb mailing list