Fwd: [linux-dvb] Twinhan 1025 problem - Knoppix works, FC4 & Ubuntu don't

Ken Harris kharris at stoic.net
Mon Apr 17 08:57:11 CEST 2006


 	Sirs:

 	I did some tests with a voltmeter and an oscilloscope a few days 
ago:

dvb-apps/test/setvoltage: doesn't seem to work
dvb-apps/test/set22k: works OK
dvb-apps/test/sendburst: doesn't seem to work
dvb-apps/test/diseqc: seems to work

An odd symptom is that when I ran 'dvbscan', then the voltage did change 
(from 13v to 19v), but I couldn't use 'setvoltage' to change it.


On Mon, 3 Apr 2006, Ken Harris wrote:

>
> 	Sirs:
>
> 	FYI, Manu's fixes work with the VP1025 and Fedora Core 4:
>
> DVB: registering new adapter (bttv0).
> dst(0) dst_get_device_id: Recognise [DST-03T]
> dst(0) dst_get_device_id: Unsupported
> dst(0) dst_get_device_id: [DST-03T] has a [Fujitsu MB86A15]
> DST type flags : 0x2 ts204 0x4 symdiv 0x10 firmware version = 2
> dst(0) dst_get_mac: MAC Address=[00:08:ca:17:49:00]
> DVB: registering frontend 0 (DST DVB-S)...
>
> 	I didn't do any of the modprobe.conf stuff.
>
> On Fri, 31 Mar 2006, Ken Harris wrote:
>
>> 	I tried to compile Manu's modules on Fedora Core 5, but I got an 
>> error:
>
>> cgi-bin-hgwebdir-cgi-v4l-algo-test-70266933831b/v4l/flexcop-usb.c:547: 
>> error: unknown field 'owner' specified in initializer
>
>> 	FYI, it compiled fine with Fedora Core 4, but I can't test it with 
>> the VP1025 because it's at work, so I should be able to test it on Monday.
>
>> On Fri, 31 Mar 2006, Ray Clouse wrote:
>
>>> This is the key email.  Get that kernel module and you should be on your 
>>> way.
>
>>> Also, you need the following in modprobe.conf:
>
>>> options dst dst_algo=0
>>> options bttv card=0x71
>>> install bttv /sbin/modprobe --ignore-install bttv && /sbin/modprobe 
>>> dvb_bt8xx
>>> remove dvb { /sbin/modprobe -r dvb-bt8xx; }
>>> alias char-major-81 bttv
>
>>> ---------- Forwarded message ----------
>>> From: Manu Abraham <abraham.manu at gmail.com>
>>> Date: Feb 8, 2006 10:41 AM
>>> Subject: Re: [linux-dvb] 	Twinhan 1025 problem - Knoppix works,	FC4 &
>>> Ubuntu don't
>>> To: Wei Weng <wweng at kencast.com>
>>> Cc: Ray Clouse <rclouse at gmail.com>, linux-dvb at linuxtv.org
>
>>> Wei Weng wrote:
>>>> Looks exactly like the problem I had been having. (No, I was not able
>>>> to figure it out)
>
>>> Please do check whether this helps ..
>
>>> http://www.thadathil.net/cgi-bin/hgwebdir.cgi/v4l-algo-test?cmd=archive;node=70266933831bc8efd85ecf808651595f79aede60;type=bz2
>
>>> For build instructions please do refer to the v4l-dvb build instructions. 
>>> A simple make should build in most cases. Would like to get your feedback 
>>> on this.
>
>>> Manu
>



More information about the linux-dvb mailing list