[linux-dvb] Can't find dvb0_0 when using dvbtune

James A Vincent pseudonoise at gmail.com
Thu Apr 20 21:48:34 CEST 2006


I am having problems in using dvbtune for ip over satellite using Linux
version 2.6.5-gentoo-r1 and a Skystar2 card.  I can use the card for dvb
tv reception with mplayer and Kaffeine with no problems.

However I cannot seem to use the card for data !

This what happens -

root at bumpkin james # dvbtune -n 512
Successfully opened network device, please configure the dvb interface

root at bumpkin james # dvbtune -f 12640000 -s 22000 -p v -D 0 -n 512
Using DVB card "STV0299/TSA5059/SL1935 based"
tuning DVB-S to L-Band:1074672480, Pol:V Srate=22000000, 22kHz=off
polling....
Getting frontend event
FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_VITERBI
FE_HAS_SYNC
Bit error rate: 346
Signal strength: 48582
SNR: 46311
FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_VITERBI
FE_HAS_SYNC
Successfully opened network device, please configure the dvb interface

root at bumpkin james # ifconfig dvb0_0
dvb0_0: error fetching interface information: Device not found

lsmod shows the following

root at bumpkin james # lsmod
Module                  Size  Used by
baycom_ser_fdx          6800  0
hdlcdrv                 9860  1 baycom_ser_fdx
ax25                   61164  1 hdlcdrv
sis900                 17156  0
it87                   20172  0
i2c_sensor              2368  1 it87
i2c_isa                 1664  0
i2c_core               19140  3 it87,i2c_sensor,i2c_isa
skystar2               25156  0
stv0299                11716  0
dvb_core               57428  2 skystar2,stv0299
fglrx                 239036  9
ohci_hcd               16900  0

I have tried using dvbnet but I get the same problem.  Could anyone
please tell me what I am doing wrong ?  I have searched the web and this
  list but I cannot find a solution.

Thanks,

James



More information about the linux-dvb mailing list