[linux-dvb] "frontend driver was not found" FC5 andoldTechnotrend card

Stuart Butterfield stuart.butterfield at philips.com
Wed Aug 2 14:00:48 CEST 2006


Hi Oliver and all,

> Stuart Butterfield wrote:
> > The working card has:
> > 
> > 01:06.0 0480: 1131:7146 (rev 01)
> >         Subsystem: 13c2:0008
> >         Flags: bus master, medium devsel, latency 32, IRQ 201
> >         Memory at df000000 (32-bit, non-prefetchable) [size=512]
> > 
> > Whereas the non-functional card has:
> > 
> > 00:09.0 0480: 1131:7146 (rev 01)
> >         Subsystem: 13c2:0001
> >         Flags: medium devsel, IRQ 10
> >         Memory at ea001000 (32-bit, non-prefetchable) [size=512]
> > 
> > Looking at av7110.c I see the problem in the switch statement on 
> > subsystem_device
> > i.e. for my non-functioning card (0001) it tries to attach to an ALPS 
> > TDLB7, 
> > whereas this card actually has the Grundig 29504-401 (as attached when 

> > 0008 is
> > seen and thus why the other card works).
> 
> Please try whether the attached patch fixes your problem.
> 
> CU
> Oliver

Sorry for the delayed response. As with my own quick hack, this patch does
indeed solve the problem. After some more testing it appears that the 
further 
problems I'm having (IP packets being received by the network stack but 
not 
the application) are caused by an, as yet unsolved, separate issue, and 
not
one to do with the specific hardware. So thanks very much for helping to 
get
me a step further.

Very best wishes.

Stuart

--
Dr Stuart Butterfield
Product Manager Mobile TV, Philips Software

Cross Oak Lane, Redhill, UK, RH1 5HA 
Mobile: +44 7887 832886
E-mail: stuart.butterfield at philips.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060802/d2d006e6/attachment.htm


More information about the linux-dvb mailing list