[linux-dvb] Compro DVB-T200A; Unable to scan

Hartmut Hackmann hartmut.hackmann at t-online.de
Mon Aug 7 23:12:27 CEST 2006


Hi, Jonas

Jonas Jonsson wrote:
> Hi..
> 
> I have two Compro DVB-T200A that I can't get to work using Linux. I have
> verified that the cards works and I can scan using Windows XP.
> 
> First I load the modules (saa7134 i2c_scan=1, saa7134-dvb, saa7134-alsa)
> and then I use dvbscan with the correct file for my location. Verified the
> freqs from the brodcasters pages, it's correct and I have manged to tune
> to that freq using Windows.
> 
> Here is modprobe, lsmod and dvbscan (The problem)
> http://pastebin.ca/121062
> 
> Here is the resulting dmesg
> http://pastebin.ca/121083
> 
> I'm running Gentoo with a 2.6.17.7 kernel with some extra patches for
> Suspend2, I have compiled the v4l-dvb drivers from HG, compiled like an
> hour ago.
> 
> Any suggestions, I'm kind of stuck right now.
> 
> /Jonas
> 
Some months ago, i have been in contact with another owner of the 200A. The
problem is that the card identifies itself as a 200, but has very different
hardware. It is a 300, but with the components for analog missing.
Please try the following:
In saa7134-dvb.c, from line 353 on, please delete the lines

	/* switch the board to dvb mode */
	init_msg.addr = 0x43;
	init_msg.len  = 0x02;
	msg[0] = 0x00;
	msg[1] = 0x40;
	if (fe->ops.i2c_gate_ctrl)
		fe->ops.i2c_gate_ctrl(fe, 1);
	if (i2c_transfer(&dev->i2c_adap, &init_msg, 1) != 1)
		return -EIO;

Recompile and unload at least the modules saa7134-dvb and saa7134.
Then reload the driver forcing the card type to 70 (the 300)

modprobe saa7134 card=70
modprobe saa7134-dvb

Now it should work. If it does, please don't forget to report this.
Afterwards, we need to find a solution we can integrate into mainline.

Best regards
    Hartmut




More information about the linux-dvb mailing list