[linux-dvb] Re: MPEG from stream file

Philip Gartrell-Mills philip at gartrellmills.wanadoo.co.uk
Sun Aug 20 12:25:34 CEST 2006


I use this software

http://www.doom9.org/index.html?/DigiTV/projectx-fullguide.htm

to convert .ts to mpeg

I hope that helps.

Phil


On Sun, 2006-08-20 at 12:00 +0200, linux-dvb-request at linuxtv.org wrote:
> Send linux-dvb mailing list submissions to
> 	linux-dvb at linuxtv.org
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> or, via email, send a message with subject or body 'help' to
> 	linux-dvb-request at linuxtv.org
> 
> You can reach the person managing the list at
> 	linux-dvb-owner at linuxtv.org
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of linux-dvb digest..."
> 
> 
> Today's Topics:
> 
>    1. MPEG from stream file (Nick Fedchik)
>    2. Hauppauge WinTV Nova-t USB Stick (Jukka-Pekka V??r?m?ki)
>    3. Re: Remote control only works after playing a channnel
>       (Thorsten Pferdek?mper)
>    4. Re: budget-ci patches (was: technotrend C1500 -bundled
>       remote...) (Darren Salt)
>    5. Re: DiB3000MC rewritten and MT2060 is ready to go into	main
>       (Patrick Boettcher)
>    6. Re: Club 3D zap250mini (Patrick Boettcher)
>    7. SAA7146 (KNC ONE DVB-C): ber values reliable? (Thomas B?rkel)
>    8. [PATCH] cx88: IR Support for Winfast DTV1000 T (Adam Zammit)
>    9. Re: RE: [linux-dvb] FusionHDTV Dual Digital zl10353 / dee1601
>       tuning (Luke Rosenthal)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sat, 19 Aug 2006 14:57:15 +0300
> From: Nick Fedchik <nick at fedchik.org.ua>
> Subject: [linux-dvb] MPEG from stream file
> To: linux-dvb at linuxtv.org
> Message-ID: <200608191457.16024.nick at fedchik.org.ua>
> Content-Type: text/plain;  charset="utf-8"
> 
> Hello, peoples! I need some help.
> 
> First I grab the stream from DVB card
> #gnutv -channels channels.conf -out file CNN.ts -timeout 60 "CNN"
> 
> Now how can I extract MPEG from CNN.ts ?
> I tried to do it using Mplayer, but it fail...
> 
> $ /usr/local/bin/mplayer  -vo xvidix -ao null cnn.ts
> MPlayer 1.0pre8-4.0.3 (C) 2000-2006 MPlayer Team
> CPU: Genuine Intel(R) CPU           T2300  @ 1.66GHz (Family: 6, Model: 14, Stepping: 8)
> CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
> Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
> 
> Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
> Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
> 
> Playing cnn.ts.
> TS file format detected.
> DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -2,
> PROBING UP TO 2000000, PROG: 0
> VIDEO MPEG2(pid=7041)AUDIO MPA(pid=7042) NO SUBS (yet)!  PROGRAM N. 7040
> Opened TS demuxer, audio: 50(pid 7042), video: 10000002(pid 7041)...POS=3008, PROBE=2000000
> parse_es: could not sync video stream!
> MPEG: FATAL: EOF while searching for sequence header.
> Video: Cannot read properties.
> ==========================================================================
> Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
> ADecoder init failed :(
> ADecoder init failed :(
> Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
> AUDIO: 16000 Hz, 2 ch, s16le, 96.0 kbit/18.75% (ratio: 12000->64000)
> Selected audio codec: [ffmp2] afm: ffmpeg (FFmpeg MPEG layer-1 and layer-2 audio decoder)
> ==========================================================================
> AO: [null] 16000Hz 2ch s16le (2 bytes per sample)
> Video: no video
> Starting playback...
> A:  -0.0 (unknown) of 1693.5 (28:13.4) ??,?%
> 
> Exiting... (End of file)
> $
> 
> Can somebody show me a good sample?
> 
> -- 
> Best regards, Nick Fedchik
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Sat, 19 Aug 2006 12:57:40 +0300
> From: Jukka-Pekka V??r?m?ki 	<jukkapekkavaaramaki at gmail.com>
> Subject: [linux-dvb] Hauppauge WinTV Nova-t USB Stick
> To: linux-dvb at linuxtv.org
> Message-ID: <44E6E094.6040304 at gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Hi!
> When will the Hauppauge WinTV Nova-t USB Stick drivers be released? 
> Patrick Boettcher wrote a while ago that he was working on them and I 
> got the impression they were nearly finished. Any ideas?
> Jukka V.
> 
> 
> 
> ------------------------------
> 
> Message: 3
> Date: Sat, 19 Aug 2006 14:57:56 +0200
> From: Thorsten Pferdek?mper
> 	<thorsten-mailbox at thorsten-pferdekaemper.de>
> Subject: Re: [linux-dvb] Remote control only works after playing a
> 	channnel
> To: linux-dvb at linuxtv.org
> Message-ID:
> 	<200608191457.57007.thorsten-mailbox at thorsten-pferdekaemper.de>
> Content-Type: text/plain;  charset="iso-8859-1"
> 
> On Tuesday 15 August 2006 07:57, Thorsten Pferdekmper wrote:
> > I have a weird problem with my remote control. It only works if I either
> > play a channel before (e.g. mplayer dvb://...) or if I remove all the cx88
> > modules and install cx88-dvb again.
> > I had a look at this using the parameter ir_debug=1 with cx88xx, so I am
> > pretty sure that this is not a problem with lircd or something else.
> >
> > Ok, this was the short version. Here is the full information.
> > The DVB card is a Hauppauge WinTV Nova-S-Plus
> > Kernel 2.6.16, compiled from source
> > Debian unstable
> > v4l-dvb package from 5.5.2006, with the nova-s-plus patch installed
> > 
> > [...]
> >
> 
> Hi,
> I have solved the problem by getting the newest v4l-dvb from mercury. 
> Regards,
> 	Thorsten
> 
> 
> 
> ------------------------------
> 
> Message: 4
> Date: Sat, 19 Aug 2006 18:41:06 +0100
> From: Darren Salt <linux at youmustbejoking.demon.co.uk>
> Subject: Re: [linux-dvb] budget-ci patches (was: technotrend C1500
> 	-bundled	remote...)
> To: linux-dvb at linuxtv.org
> Message-ID: <4E58F391A8%linux at youmustbejoking.demon.co.uk>
> Content-Type: text/plain; charset=us-ascii
> 
> I demand that Jussi Kukkonen may or may not have written...
> 
> > Lainaus Darren Salt <linux at youmustbejoking.demon.co.uk>:
> >> The budget-ci patches need somebody to maintain them and get them included
> >> in the main repository. There is a little work to be done on them, but I
> >> can only compile-test these days.
> 
> >> If you want to take them on, that'd be good...
> 
> > I'm not at all sure my skills are up to that, but... Would you, or anyone,
> > mind explaining the situation to a v4l-dvb (and
> > kernel-module-dev-in-general) newbie?
> 
> Well... they've been posted here and some of them were almost included once.
> 
> > Is there something in the design that has prevented them from being
> > included or do they just need the testing?
> 
> Testing and, for one of the patches, debugging. I think that the repeat,
> device name truncation avoidance, EVIOCGPHYS and kzalloc patches can go
> straight in, modulo possible bit-rot; I'm fairly sure that the ir-common
> usage patch can go in (for one thing, it provides the correct default keymap
> for the R808 remote control which was supplied with some Nova-Ts). However,
> the shutdown patch needs some debugging.
> 
> > What kind of a timeline/process is typical or expected here?
> 
> It seems to be very variable. :-|
> 
> -- 
> | Darren Salt    | linux or ds at              | nr. Ashington, | Toon
> | RISC OS, Linux | youmustbejoking,demon,co,uk | Northumberland | Army
> |   <URL:http://www.youmustbejoking.demon.co.uk/> (PGP 2.6, GPG keys)
> 
> Growing old is mandatory; growing up is optional!
> 
> 
> 
> ------------------------------
> 
> Message: 5
> Date: Sat, 19 Aug 2006 21:15:26 +0200 (CEST)
> From: Patrick Boettcher <patrick.boettcher at desy.de>
> Subject: Re: [linux-dvb] DiB3000MC rewritten and MT2060 is ready to go
> 	into	main
> To: matthieu castet <castet.matthieu at free.fr>
> Cc: linux-dvb at linuxtv.org
> Message-ID: <Pine.LNX.4.64.0608192114150.6507 at pub1.ifh.de>
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> 
> Hi Matthieu,
> 
> I added something to my repository which should fix it:
> 
> Can you give it a try:
> http://linuxtv.org/hg/~pb/v4l-dvb
> 
> Thanks for finding the problem,
> Patrick.
> 
> --
>   Mail: patrick.boettcher at desy.de
>   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/
> 
> 
> 
> On Fri, 18 Aug 2006, matthieu castet wrote:
> 
> > Hi,
> > Patrick Boettcher wrote:
> > > Hi,
> > > 
> > > On Thu, 17 Aug 2006, matthieu castet wrote:
> > > 
> > > > > >Are you running on USB2.0?
> > > > >
> > > > >No usb1.1
> > > > >
> > > > >On usb2.0 it seems to work (but the configuration is a bit different).
> > > > >Is there a way to check if the usb bandwidht don't overflow because of
> > > > >bad
> > > > >filtering ?
> > > 
> > > 
> > > So OK, it is definitely only the PID filter functionality somewhere. It can
> > > be the dib3000mc or the use of the interface.
> > > 
> > > It will only be a small fix and there is only a few people having only
> > > USB1.1. It is save to merge it into mainline and then send a patch for
> > > fixing later.
> > > 
> > > How are you coding abilities? Can you check if dib3000mc_pid_parse is called
> > > with onoff 1 and if the bit is set correcly by reading it back.
> > > 
> > Yes it is set correctly, but look what you do in dib3000mc_set_output_mode :
> > 
> > case OUTMODE_MPEG2_FIFO:            // e.g. USB feeding 
> >                 elecout = 3;
> >                         /*ADDR @ 206 :
> >                         P_smo_error_discard  [1;6:6] = 0
> >                         P_smo_rs_discard     [1;5:5] = 0
> >                         P_smo_pid_parse      [1;4:4] = 0
> > 						^^^^^^^^ ooppps we don't whant
> > to touch this one : it is set by dib3000mc_pid_parse.
> >                         P_smo_fifo_flush     [1;3:3] = 0
> >                         P_smo_mode           [2;2:1] = 11
> >                         P_smo_ovf_prot       [1;0:0] = 0
> >                         */
> >                         smo_reg = (0 << 6) | (0 << 5) | (0 << 4) | (0 
> > << 3) |(3 << 1) | 0;
> >                         fifo_threshold = 512;
> >                         outmode = 5;
> >                         break;
> > 
> > If I put smo_reg = (0 << 6) | (0 << 5) | (1 << 4) | (0 << 3) |(3 << 1) | 0;
> > it works :)
> > 
> > There is 2 solutions to solve the problem :
> > - smo_reg is only set at init time
> > - we don't touch bit 4 in dib3000mc_set_output_mode
> > 
> > Matthieu
> > 
> 
> 
> 
> ------------------------------
> 
> Message: 6
> Date: Sat, 19 Aug 2006 21:16:53 +0200 (CEST)
> From: Patrick Boettcher <patrick.boettcher at desy.de>
> Subject: Re: [linux-dvb] Club 3D zap250mini
> To: Jochen Issing <jochen at isign-softart.de>
> Cc: linux-dvb at linuxtv.org
> Message-ID: <Pine.LNX.4.64.0608192115360.6507 at pub1.ifh.de>
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> 
> Hi Jochen,
> 
> I applied and committed your patch with a slight modification to my 
> repository. I will send the pull-request to Mauro after your confirmation.
> 
> thanks for the patch,
> Patrick.
> 
> --
>   Mail: patrick.boettcher at desy.de
>   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/
> 
> 
> On Sun, 13 Aug 2006, Jochen Issing wrote:
> > After some structural changes, here comes the updated patch for the Club 3D 
> > zap250mini USB dvb device.
> > 
> > If there are still some things incorrect, please let me know and I will try to 
> > correct it.
> > 
> > Cheers,
> > 
> > jochen
> 
> 
> 
> 
> ------------------------------
> 
> Message: 7
> Date: Sun, 20 Aug 2006 00:55:24 +0200
> From: Thomas B?rkel <thomas at boerkel.de>
> Subject: [linux-dvb] SAA7146 (KNC ONE DVB-C): ber values reliable?
> To: linux-dvb <linux-dvb at linuxtv.org>
> Message-ID: <44E796DC.3080200 at boerkel.de>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> HI!
> 
> I am using KNC ONE DVB-C (budget_av) with kernel 2.6.16.
> 
> Whatever I do (different cables, changing amplification, switching 
> channels), czap always reports a ber of 195000.
> 
> Recently I got a second card and it's the same there. Only on one 
> occasion, I suddenly had a ber of 50 on the new card. After reboot, it 
> was back to 195000.
> 
> Now I installed recent (1-2 weeks old) development version of the 
> drivers and now one card has again always a ber of 195000 and the other 
> one has always 194ef2.
> 
> My question is: Is the ber reliable from this card?
> 
> Thanks!
> 
> Thomas
> 
> 
> 
> 
> ------------------------------
> 
> Message: 8
> Date: Sun, 20 Aug 2006 11:24:45 +1000
> From: Adam Zammit <adam at foaz.com>
> Subject: [linux-dvb] [PATCH] cx88: IR Support for Winfast DTV1000 T
> To: linux-dvb at linuxtv.org
> Message-ID: <44E7B9DD.90807 at foaz.com>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Hello,
> 
> Can someone please verify that this patch works for them. Included is
> and update to the keys for the Y04G0004 controller that came in the box
> with my Winfast DTV1000 T (purchased in Australia). The patch was
> written against 2.6.17.8 vanilla.
> 
> Regards,
> Adam Zammit
> 
> 
> ---
> 
> -------------- next part --------------
> --- a/linux/drivers/media/common/ir-keymaps.c	2006-08-07 14:18:54.000000000 +1000
> +++ b/linux/drivers/media/common/ir-keymaps.c	2006-08-17 01:04:28.000000000 +1000
> @@ -1285,7 +1285,25 @@
>  	[ 0x23 ] = KEY_PLAYPAUSE,
>  	[ 0x24 ] = KEY_NEXT,
>  	[ 0x26 ] = KEY_STOP,
> -	[ 0x27 ] = KEY_RECORD
> +	[ 0x27 ] = KEY_RECORD,
> +
> +	/* Added by Adam for Y04G0004 Control */
> +	[ 0x36 ] = KEY_TV,
> +	[ 0x37 ] = KEY_RADIO,
> +	[ 0x38 ] = KEY_DVD,
> +	[ 0x29 ] = KEY_EXIT,
> +	[ 0x30 ] = KEY_CHANNEL,
> +	[ 0x2f ] = KEY_MENU,
> +	[ 0x31 ] = KEY_EPG,
> +	[ 0x32 ] = KEY_CHANNEL,
> +	[ 0x33 ] = KEY_LANGUAGE,
> +	[ 0x1e ] = KEY_VIDEO,
> +	[ 0x1b ] = KEY_AUDIO,
> +	[ 0x16 ] = KEY_SUBTITLE,
> +	[ 0x11 ] = KEY_BACK,
> +	[ 0x28 ] = KEY_SHUFFLE,
> +	[ 0x25 ] = KEY_F23,
> +	[ 0x2a ] = KEY_MODE
>  };
>  
>  EXPORT_SYMBOL_GPL(ir_codes_winfast);
> --- a/linux/drivers/media/video/cx88/cx88-cards.c	2006-08-07 14:18:54.000000000 +1000
> +++ b/linux/drivers/media/video/cx88/cx88-cards.c	2006-08-17 01:05:13.000000000 +1000
> @@ -865,6 +865,10 @@
>  		.input          = {{
>  			.type   = CX88_VMUX_DVB,
>  			.vmux   = 0,
> +			.gpio0	= 0x00F5e700,
> +			.gpio1  = 0x00003004,
> +			.gpio2  = 0x00F5e700,
> +			.gpio3  = 0x02000000,
>  		}},
>  		.dvb            = 1,
>  	},
> --- a/linux/drivers/media/video/cx88/cx88-input.c	2006-08-07 14:18:54.000000000 +1000
> +++ b/linux/drivers/media/video/cx88/cx88-input.c	2006-08-17 01:04:56.000000000 +1000
> @@ -173,6 +173,7 @@
>  		ir->sampling = 1;
>  		break;
>  	case CX88_BOARD_WINFAST2000XP_EXPERT:
> +	case CX88_BOARD_WINFAST_DTV1000:
>  		ir_codes = ir_codes_winfast;
>  		ir->gpio_addr = MO_GP0_IO;
>  		ir->mask_keycode = 0x8f8;
> 
> ------------------------------
> 
> Message: 9
> Date: Sun, 20 Aug 2006 19:46:57 +1000 (EST)
> From: "Luke Rosenthal" <linux-dvb at harderstuff.net>
> Subject: Re: RE: [linux-dvb] FusionHDTV Dual Digital zl10353 / dee1601
> 	tuning
> To: linux-dvb at linuxtv.org
> Message-ID: <1180.192.168.2.50.1156067217.squirrel at mail.luko.org>
> Content-Type: text/plain;charset=iso-8859-1
> 
> >> I'm having a few probs compiling on FC5:
> >>
> >> hg clone http://linuxtv.org/hg/v4l-dvb/ cd v4l-dvb make
> >>
> >> I get the following errors:
> >>
> >> /tmp/v4l-dvb/v4l/dvb_net.c: In function 'wq_set_multicast_list':
> >> /tmp/v4l-dvb/v4l/dvb_net.c:1141: error: 'struct net_device' has no
> >> member named 'xmit_lock' /tmp/v4l-dvb/v4l/dvb_net.c:1170: error: 'struct
> >> net_device' has no member named 'xmit_lock'
> >>
> >> Compiling against 2.6.17-1.2174_FC5, I have the following kernel
> >> packages installed:
> >>
> >> kernel-2.6.17-1.2145_FC5.i686.rpm kernel-2.6.17-1.2174_FC5.i686.rpm
> >> kernel-devel-2.6.17-1.2174_FC5.i686.rpm
> >>
> >> Am I doing something wrong?  I have been able to compile the v4l-dvb
> >> tree before as recently as a week ago (altho that was against
> >> 2.6.17-1.2145, I think)
> >
> > [snip, snip]
> >
> > IIRC, the FC5 2.6.17 kernels are actually based on 2.6.18, so this
> > problem can be fixed by doing small changes to the dvb_net.c file.
> >
> > Find the function wq_set_multicast_list and change the two occurrences of
> >
> > #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
> >
> > to
> >
> > #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,17)
> >
> > so that xmit_lock won't be used. Works for me.
> 
> Perfect, this worked a treat - I can confirm the v4l-dvb tree from
> linuxtv.org now compiles against kernel-2.6.17-1.2174_FC5 when the above
> tweaks are made.
> 
> Thanks very much!!
> 
> Luke.
> 
> 
> 
> 
> 
> ------------------------------
> 
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
> 
> End of linux-dvb Digest, Vol 19, Issue 53
> *****************************************
> 





More information about the linux-dvb mailing list