[linux-dvb] Budget card does not work on Fedora Core 5

Thomas Börkel thomas at boerkel.de
Sun Aug 20 16:12:51 CEST 2006


HI!

I have a KNC ONE budget DVB-C card, that works out of the box in a Suse
10.1 machine. Now that I transferred the card to a Fedora Core 5
machine, I can't get it to work.

lspci finds the card:
02:0b.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
         Subsystem: KNC One Unknown device 0020
         Flags: bus master, medium devsel, latency 32, IRQ 9
         Memory at e1800000 (32-bit, non-prefetchable) [size=512]

budget_av was automatically loaded:
[root at backend ~]# lsmod
Module                  Size  Used by
nfsd                  204241  17
lockd                  55497  2 nfsd
nfs_acl                 3649  1 nfsd
autofs4                19141  1
hidp                   16065  2
rfcomm                 34901  0
l2cap                  23617  10 hidp,rfcomm
bluetooth              44709  5 hidp,rfcomm,l2cap
sunrpc                139389  12 nfsd,lockd,nfs_acl
xfs                   472548  2
exportfs                5697  2 nfsd,xfs
dm_mirror              20881  0
dm_mod                 52313  1 dm_mirror
video                  15173  0
button                  6609  0
battery                 9285  0
ac                      4933  0
ipv6                  225825  20
lp                     12169  0
parport_pc             25573  0
parport                34569  2 lp,parport_pc
nvram                   8393  0
budget_av              16321  0
dvb_pll                11333  1 budget_av
saa7146_vv             43585  1 budget_av
video_buf              21829  1 saa7146_vv
budget_core            10057  1 budget_av
saa7146                17737  3 budget_av,saa7146_vv,budget_core
ttpci_eeprom            2625  1 budget_core
stv0299                 9801  1 budget_av
dvb_core               74601  3 budget_av,budget_core,stv0299
tda10021                5829  1 budget_av
tda1004x               13381  1 budget_av
uhci_hcd               29393  0
stradis                36065  0
msp3400                28641  0
saa7127                10837  0
saa7115                13265  0
tda9887                15185  0
tuner                  46329  0
v4l2_common             7745  3 saa7146_vv,msp3400,tuner
ivtv                  161040  0
natsemi                24737  0
v4l1_compat            11973  2 saa7146_vv,ivtv
compat_ioctl32          1473  1 stradis
tveeprom               13905  1 ivtv
videodev                9409  3 saa7146_vv,stradis,ivtv
nvidia               4521844  12
i2c_i801                8525  0
hw_random               5849  0
i2c_core               21057  15 
budget_av,budget_core,ttpci_eeprom,stv0299,tda10021,tda1004x,msp3400,saa7127,saa7115,tda9887,tuner,ivtv,tveeprom,nvidia,i2c_i801
ext3                  116681  2
jbd                    52821  1 ext3


Device nodes were not created automatically, so I created them like this:
[root at backend download]# ls -la /dev/dvb/adapter0/
total 0
drwxr-xr-x 2 root   root    200 Aug 20 15:47 .
drwxr-xr-x 6 root   root    120 Aug 20 15:47 ..
crw-rw---- 1 mythtv root 212, 1 Aug 20 15:47 audio0
crw-rw---- 1 mythtv root 212, 6 Aug 20 15:47 ca0
crw-rw---- 1 mythtv root 212, 4 Aug 20 15:47 demux0
crw-rw---- 1 mythtv root 212, 5 Aug 20 15:47 dvr0
crw-rw---- 1 mythtv root 212, 3 Aug 20 15:47 frontend0
crw-rw---- 1 mythtv root 212, 7 Aug 20 15:47 net0
crw-rw---- 1 mythtv root 212, 8 Aug 20 15:47 osd0
crw-rw---- 1 mythtv root 212, 0 Aug 20 15:47 video0

Still I get an error from scandvb:
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
main:2247: FATAL: failed to open '/dev/dvb/adapter0/frontend0': 19 No
such device

Any help would be greatly appreciated.

Thomas





More information about the linux-dvb mailing list