[linux-dvb] Hauppauge DEC3000-s lockup under Linux 2.6.18

Benjamin Eikel benjamin.eikel at gmx.de
Fri Dec 8 22:54:11 CET 2006


Am Samstag, 30. September 2006 21:03 schrieb Jens Krehbiel-Gräther:
> Benjamin Eikel schrieb:
> > Hello!
> >
> > I try to use a Hauppauge DEC3000-s USB box with my Linux machine. I am
> > using a self-compiled kernel 2.6.18 from kernel.org.
> > The firmware seems to be loaded:
> > dmesg output:
> > ohci_hcd 0000:00:02.0: wakeup
> > usb 2-3: new full speed USB device using ohci_hcd and address 6
> > usb 2-3: device descriptor read/64, error -110
> > usb 2-3: configuration #1 chosen from 1 choice
> > ttusb_dec: Firmware 2.28<6>ttusb_dec: found DSP code "DEC2540-t".
> > usb 2-3: USB disconnect, address 6
> > ohci_hcd 0000:00:02.0: wakeup
> > usb 2-3: new full speed USB device using ohci_hcd and address 7
> > usb 2-3: configuration #1 chosen from 1 choice
> > DVB: registering new adapter (DEC3000-s).
> > DVB: registering frontend 0 (TechnoTrend/Hauppauge DEC3000-s Frontend)...
> >
> > The devices under /dev/dvb/adapter0/ are created. But I get an error when
> > I try to scan:
> > scan /usr/share/doc/dvb-utils/examples/scan/dvb-s/Astra-19.2E | tee
> > channels.conf
> > scanning /usr/share/doc/dvb-utils/examples/scan/dvb-s/Astra-19.2E
> > using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> > initial transponder 12551500 V 22000000 5
> >
> >>>> tune to: 12551:v:0:22000
> >
> > __tune_to_transponder:1491: ERROR: FE_READ_STATUS failed: 5 Input/output
> > error
> >
> >>>> tune to: 12551:v:0:22000
> >
> > __tune_to_transponder:1491: ERROR: FE_READ_STATUS failed: 5 Input/output
> > error ERROR: initial tuning failed
> > dumping lists (0 services)
> > Done.
> >
> > dmesg gives:
> > ttusbdecfe_read_status: returned unknown value: 0
> > ttusbdecfe_read_status: returned unknown value: 0
> > ttusbdecfe_read_status: returned unknown value: 0
> > ...
> >
> > I do not know if this is okay, but the box seems to hang after the
> > firmware has been loaded. I cannot turn it off with the remote control
> > anymore.
> >
> > I have tried to find some information about these error messages but had
> > no luck. I hope that you can tell me what I am doing wrong.
>
> Hi Benjamin!
>
> I have a DEC3000-s and the same problems under linux. I postet my error
> messages in april to the linux-dvb-list, but no one could help me.
>
> The only thing I can help you is about the "hang" after the firmware
> loaded. If you installed dvb-utils (or compiled them from source) you
> can get the box back to normal operation by typing the command
> "ttusb_dec_reset". Then the box gets back to normal operation. My
> linux-box then loads the driver immidiatly again, so perhaps you have to
> shut down hotplug bevor resetting the box.
>
> But it would be great if someone can help us with the problem. I can
> make usbsnoop under windows if it could help (i already made half a year
> ago, but nothing happened since then :-()
>
> Jens
>
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

Hello Jens,

no news from my side yet. I tried Linux 2.6.19 today but still exactly the 
same behavior as mentioned in my first post.

Regards,
Benjamin



More information about the linux-dvb mailing list