[linux-dvb] Pinnacle 300i

hermann pitton hermann.pitton at onlinehome.de
Fri Feb 3 21:10:28 CET 2006


Am Freitag, den 03.02.2006, 15:55 +0000 schrieb Mike Ferenduros:
> Hi,
> 
> Ah, the tuner module detects the mt2050 ok if I load tda9887 first, thanks 
> for the hint.
> 
> Digital tuning is still broken though...there are no i2c problems I can see, 
> and the mt2050 says it's tuning to the right frequency, but nothing happens 
> beyond that.

Interesting, we had lots of changes in the tuner area, but maybe the
problem is somewhere else. After you try digital does the analog still
work then?

> Could anyone provide a log of a 300i doing a successful scan?

Maybe Rainer can. The next suspect would be the TS interface then and
one can enable debug for video-buf-dvb and ts_debug=1 for saa7134, see
"modinfo saa7134" for further parameters. The changes here are _very_
limited and Hartmut discussed them with Gerd, but I don't know if the
saa7134 chip has been tested explicitly, since we are all mostly on
saa7135 and 7131e, if it matters at all.

Since Rainer says 20050627 works, there are only
> http://www.linuxtv.org/cgi-bin/viewcvs.cgi/v4l-dvb/linux/drivers/media/video/saa7134/saa7134-ts.c?root=v4l&r1=1.14&r2=1.15
which Gerd explicitly changed the other way round previously for 300i
and
> http://www.linuxtv.org/cgi-bin/viewcvs.cgi/v4l-dvb/linux/drivers/media/video/saa7134/saa7134-ts.c?root=v4l&r1=1.16&r2=1.17
But you might have a look yourself with viewcvs.
For the few changes in video-buf-dvb I assume no problems
and these here are also only shots in the dark, since you seem to have
no visible error messages. Strange.

Cheers,
Hermann







More information about the linux-dvb mailing list