[linux-dvb] Twinhan 1025 problem - Knoppix works, FC4 & Ubuntu don't

Ray Clouse rclouse at gmail.com
Wed Feb 8 21:21:45 CET 2006


Worked.  What changed to get it recognized?

Here's my dmesg output:

i2c_adapter i2c-0: nForce2 SMBus adapter at 0x5000
i2c_adapter i2c-1: nForce2 SMBus adapter at 0x5100
Linux video capture interface: v1.00
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 11
ACPI: PCI Interrupt 0000:01:08.0[A] -> Link [LNK1] -> GSI 11 (level,
low) -> IRQ 11
bttv0: Bt878 (rev 17) at 0000:01:08.0, irq: 11, latency: 32, mmio: 0xdc000000
bttv0: detected: Twinhan VisionPlus DVB [card=113], PCI subsystem ID
is 1822:0001
bttv0: using: Twinhan DST + clones [card=113,insmod option]
bttv0: gpio: en=00000000, out=00000000 in=00d500ff [init]
bttv0: using tuner=4
bttv0: add subdevice "dvb0"
bttv: Bt8xx card found (1).
ACPI: PCI Interrupt 0000:01:0a.0[A] -> Link [LNK3] -> GSI 10 (level,
low) -> IRQ 10
bttv1: Bt878 (rev 17) at 0000:01:0a.0, irq: 10, latency: 32, mmio: 0xdc002000
bttv1: detected: AVerMedia TVCapture 98 [card=13], PCI subsystem ID is 1461:0004
bttv1: using: AVerMedia TVCapture 98 [card=13,autodetected]
bttv1: gpio: en=00000000, out=00000000 in=00fff7c3 [init]
bttv1: Hauppauge/Voodoo msp34xx: reset line init [11]
tuner 3-0061: chip found @ 0xc2 (bt878 #1 [sw])
bttv1: Avermedia eeprom[0x4002]: tuner=2 radio:no remote control:no
bttv1: using tuner=2
tuner 3-0061: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
bttv1: i2c: checking for MSP34xx @ 0x80... not found
bttv1: i2c: checking for MSP34xx (alternate address) @ 0x88... not found
bttv1: i2c: checking for TDA9875 @ 0xb0... not found
bttv1: i2c: checking for TDA7432 @ 0x8a... not found
bttv1: i2c: checking for TDA9887 @ 0x86... not found
bttv1: registered device video0
bttv1: registered device vbi0
bttv1: PLL: 28636363 => 35468950 .. ok
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:01:08.1[A] -> Link [LNK1] -> GSI 11 (level,
low) -> IRQ 11
bt878(0): Bt878 (rev 17) at 01:08.1, irq: 11, latency: 32, memory: 0xdc001000
bt878: Bt878 AUDIO function found (1).
ACPI: PCI Interrupt 0000:01:0a.1[A] -> Link [LNK3] -> GSI 10 (level,
low) -> IRQ 10
bt878(1): Bt878 (rev 17) at 01:0a.1, irq: 10, latency: 32, memory: 0xdc003000
DVB: registering new adapter (bttv0).
dst(0) dst_get_device_id: Recognise [DST-03T]
dst(0) dst_get_device_id: Unsupported
dst(0) dst_get_device_id: [DST-03T] has a [Fujitsu MB86A15]
DST type flags : 0x2 ts204 0x4 symdiv 0x10 firmware version = 2
dst(0) dst_get_mac: MAC Address=[00:08:ca:17:48:00]
DVB: registering frontend 0 (DST DVB-S)...

it's there:
[root at sat ~]# ls /dev/dvb/adapter0/
demux0  dvr0  frontend0  net0


On 2/8/06, Manu Abraham <abraham.manu at gmail.com> wrote:
> Wei Weng wrote:
> > Looks exactly like the problem I had been having. (No, I was not able
> > to figure it out)
>
> Please do check whether this helps ..
>
> http://www.thadathil.net/cgi-bin/hgwebdir.cgi/v4l-algo-test?cmd=archive;node=70266933831bc8efd85ecf808651595f79aede60;type=bz2
>
> For build instructions please do refer to the v4l-dvb build
> instructions. A simple
> make
> should build in most cases. Would like to get your feedback on this.
>
>
> Manu
>
>



More information about the linux-dvb mailing list