[linux-dvb] Pinnacle 310i, DVB-T

Pierluigi 'Lanugo' Rolando lanugo at ica-net.it
Sun Feb 12 13:37:58 CET 2006


Il giorno dom, 12/02/2006 alle 12.38 +0100, tim0m1a ha scritto: 
> you would have some trouble to get the pinnacle running under  
> kernel-versions newer than 2.6.12 but as you use a 2.6.12-Kernel-Version  
> you should try this v4l-snapshot:
> http://www.linuxtv.org/downloads/video4linux/video4linux-20050627.tar.gz
> This works fine for me, but it is the only snapshot working on my machine.

I'm afraid I have trouble installing the snapshot. I untar/gz it in a
new directory, then type make and finally make install. Everything seems
to be ok, but then when I modprobe saa7134-dvb the module doesn't load:

Linux video capture interface: v1.00
saa7130/34: v4l2 driver version 0.2.13 loaded
saa7130/34: snapshot date 2005-06-27
ACPI: PCI Interrupt 0000:05:07.0[A] -> Link [APC2] -> GSI 17 (level,
low) -> IRQ 17
saa7133[0]: found at 0000:05:07.0, rev: 208, irq: 17, latency: 32, mmio:
0xd900a000
saa7133[0]: subsystem: 11bd:002f, board: UNKNOWN/GENERIC
[card=0,autodetected]
saa7133[0]: board init: gpio is 600e000
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: i2c eeprom read error (err=-5)
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7134_dvb: Unknown symbol videobuf_dvb_unregister
saa7134_dvb: Unknown symbol videobuf_dvb_register
video_buf_dvb: disagrees about version of symbol dvb_dmxdev_init
video_buf_dvb: Unknown symbol dvb_dmxdev_init
video_buf_dvb: disagrees about version of symbol dvb_dmx_release
video_buf_dvb: Unknown symbol dvb_dmx_release
video_buf_dvb: disagrees about version of symbol dvb_net_init
video_buf_dvb: Unknown symbol dvb_net_init
video_buf_dvb: disagrees about version of symbol dvb_dmx_swfilter
video_buf_dvb: Unknown symbol dvb_dmx_swfilter
video_buf_dvb: disagrees about version of symbol dvb_dmxdev_release
video_buf_dvb: Unknown symbol dvb_dmxdev_release
video_buf_dvb: disagrees about version of symbol dvb_net_release
video_buf_dvb: Unknown symbol dvb_net_release
video_buf_dvb: disagrees about version of symbol dvb_unregister_frontend
video_buf_dvb: Unknown symbol dvb_unregister_frontend
video_buf_dvb: disagrees about version of symbol dvb_register_frontend
video_buf_dvb: Unknown symbol dvb_register_frontend
video_buf_dvb: disagrees about version of symbol dvb_dmx_init
video_buf_dvb: Unknown symbol dvb_dmx_init
saa7134_dvb: Unknown symbol videobuf_dvb_unregister
saa7134_dvb: Unknown symbol videobuf_dvb_register

I think that there might be some missing modules, as if I manually
remove every v4l module in my system and then try to reinstall the
snapshot, when I modprobe saa7134-dvb many more missing symboles are
found.

How should I use that snapshot?

> Please keep in mind, that you must flash at least the 1.11-Firmware  
> version onto your card via Windows, otherwise the card would not work.

I'm afraid I have no way to flash the firmware. In fact, I even think
that there is no eprom chip to flash on my card. Under Windows I can
only flash a 300i card, I do not have any utilities on the Pinnacle
install cds to flash the 310i card.

Regards,
Pierluigi





More information about the linux-dvb mailing list