[linux-dvb] Pinnacle 300i, please try this patch

Hartmut Hackmann hartmut.hackmann at t-online.de
Thu Feb 16 00:00:37 CET 2006


Hi, Tim, Rainer

Tim Small wrote:
> I tested Hartmut's patch yesterday - analogue now works, (the picture 
> was horrible, but this is apparently because a workman has broken the 
> cable in the roof space - I will test digital after I have fixed the 
> cable!).  With the patch I've not seen any more i2c errors anyway.
> 
> Rainer Schubert wrote:
> 
>> After I had patches the latest mercurial sources, I had the same 
>> errors as before again.
>>
>> Yesterday I used HG to download the sources for v4l-dvb and patched
>> them with Hartmut's patch.  It seems there has been one reject this
>> time.
>>
>> Make and make install worked fine but depmod complains about differences
>> in module versions or symbole versions, I can't remember at the moment.
> 
> 
> Use a more recent kernel, and apply the rejected diff by hand (i.e. just 
> look at the contents of the diff, and make the change yourself), or tell 
> patch to try harder.
> 
The patch was created against an about 1 week old version, it is quite likely
that it changed meanwhile. I guess the patches in saa7134-cards.c were rejected.
Please apply the changes manually - at least the one for the pinnacle 300i.
It is a major portion of the trick. Also please keep in mind that the tda9887
module needs to be loaded manually before tuner. I have a patch for this
pending.
If you have inconsistent module versions, i guess the reason is that the
kernel is older than 2.6.12. In this case, the dvb modules will not be updated.
If it is desired, i can also generate a patch for this to make it work for
at least 2.6.11.

Hartmut



More information about the linux-dvb mailing list