[linux-dvb] Budget card with CI seen as "budget", not "budget-ci"

Pavel Paprok ppaprok at applet.cz
Fri Feb 17 14:26:14 CET 2006

Hi all,

I just playing with some dvb-s card, ordered as "Win TV-NOVA CI".
(but based on info on attached cd it is "TT-budget S-1500")
This card came with CI extension board, so I want to use it to receiving
some Cryptoworks encrypted programs, in conjunction with
SCM Cryptoworks adapter a Cryptoworks card.
Kernel is latest, latest mercurial, player is latest
vlc /w dvb support compiled in.

 ...is that pci subid of card (0x017) cause detect and serve it by "budget"
driver instead "budget-ci", so CI option is unavailable:

Feb 14 04:08:18 dvbfm kernel: DVB: registering new adapter (TT-Budget/WinTV-NOVA
-S PCI (rev AL/alps bsbe1 lnbp21 frontend)).

Note that all free-to-air programs works with autoloaded "budget" driver great,
but because I really WANT to use CI on this card I did these tests:
1) simple move subid 0x017 from budget driver to budget-ci driver
-> after this change CI was initialized, CAM detected, but tuner do not get lock.
As I found, tuner BSBE1 which is on card really presented is not supported
on "budget-ci" (budget-ci coded only for WinTV with BSRU6 tuner)

2) so next - because card did work with "budget" driver ok before -  I try to copy
also bsbe1/lnbp21 related parts of code analogically from "budget" to "budget-ci"
(functions  like alps_bsbe1_inittab, alps_bsbe1_set_symbol_rate, alps_bsbe1_pll_set,
lnbp21_set_voltage, lnbp21_enable_high_lnb_voltage, lnbp21_init)

after this change card seen as budget-ci card:

Feb 14 15:12:29 dvbfm kernel: saa7146: found saa7146 @ mem df896400 (revision 1,
 irq 177) (0x13c2,0x1017).
Feb 14 15:12:29 dvbfm kernel: DVB: registering new adapter (TT-Budget/WinTV-NOVA
Feb 14 15:12:29 dvbfm kernel: adapter has MAC addr = 00:d0:5c:04:72:a1
Feb 14 15:12:29 dvbfm kernel: input: Budget-CI dvb ir receiver saa7146 (1) as /c
Feb 14 15:12:29 dvbfm kernel: budget_ci: CI interface initialised
Feb 14 15:12:29 dvbfm kernel: DVB: registering frontend 1 (ST STV0299 DVB-S)...
Feb 14 15:12:31 dvbfm kernel: dvb_ca adapter 0: DVB CAM detected and initialised


FREE programs works still great (like before), without any errors.
CRYPOTWORKS programs start playing ok too, but stream seems
to have a some quality problems:
- sometime errors in picture observed (3-30% of screen, once per 10-60sec)
but not reported by input in vlc. On screen it seems like errors in stream,
but signal is ok (all free programs on same transponder works great)
- sometime screen freezes for 5-20 seconds (once per 1-3 minutes) , vlc
reporting ussualy some changing of rate ended with new lock of tuner
during this time.


what cause these errors in receiving of Cryptoworks programs? some
next changes of code or configuration recommended? some tips?
it is a last, but essential problem of my vlc stream,
and I am open to help to assist in test with my hardware :-)

which is best way to assure that card with subid 0x017 will be in next
releases of kernels detected by right, modified "budget-ci" driver?
(only in case if problem in first question solved :-) )


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20060217/3e2b502d/attachment.htm

More information about the linux-dvb mailing list