[linux-dvb] Pinnacle 300i, please try this patch WORKING !

Hartmut Hackmann hartmut.hackmann at t-online.de
Sun Feb 19 01:10:49 CET 2006


Hi

Rainer Schubert wrote:
> On Fri, 17 Feb 2006, Hartmut Hackmann wrote:
> 
>> Hi,
> 
> 
> Hi all,
> 
> [...]
> 
>> I will attach the patch that hopefully fixes the module load order issue.
>> I haven't updated my workspace for a while, so it might be that it 
>> does not
>> apply out of the box.
> 
> 
> Thanks Hartmut for that one ! The card finally works, even with a small
> non-amplified indoor antenna, which originally belongs to the Cinergy T²
> device.
> 
> What I have done is apply your (Hartmut's) patch on top of the one Hermann
> did supply, issue "make clean;make;make install;reboot" and try the card
> under Windows to make sure it is not broken.
> 
>> The main thing is in the tda8290.c. If probing for the tda8290 fails, the
>> code now assumes it is a tda9886 and restores its power on defaults.
> 
> 
> There are still some issues, as the card ignores some of the transponders
> in my dvb-t/de-Hamburg file, which it was able to receive in June last
> year, but I am happy to see it working again !
> 
Aha, so it was the module load order issue. But for the next time, please
stick to the instructions we give.

Regarding the transponders: This is not a problem with the driver. The
channel assignment was changed. You need to get a recent initial config
file and to rescan.

Best regards
    Hartmut



More information about the linux-dvb mailing list