[linux-dvb] Another Twinhan VP20310 problem

J. van Amerongen joel at jovana.nl
Sun Jan 8 11:50:44 CET 2006


I have already going through:
http://www.linuxtv.org/pipermail/linux-dvb/2005-September/004871.html

The card can tune and scan. But no picture.
I have try:

peterr-alfa2 ~ # czap "RTL 5"
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
reading channels from file '/root/.czap/channels.conf'
  4 RTL 5:340000000:INVERSION_AUTO:6875000:FEC_NONE:QAM_64:1910:1911:2009
  4 RTL 5: f 340000000, s 6875000, i 2, fec 0, qam 3, v 0x776, a 0x777
status 00 | signal 0000 | snr 0000 | ber 6e65672d | unc 34312e36 |
status 1f | signal 0000 | snr 3200 | ber 6e65672d | unc 34312e36 |
FE_HAS_LOCK
status 1f | signal 0000 | snr 3200 | ber 6e65672d | unc 34312e36 |
FE_HAS_LOCK

And:

peterr-alfa2 ~ # cat /dev/dvb/adapter0/dvr0 > /data/test.ts
The test.ts is 0 bytes and wont play.

And:

Mplayer dvb://"RTL 5"
Mplayer crashed because it can't read the stream.

If I start the czap command this will written in the dmesg (a peace of it):

rdc_reset_state: Resetting state machine
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0000]
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0002]
writing [ 09 00 05 30 20 00 1a db 40 6d ]
dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
read_dst: reply is 0xff
dst_wait_dst_ready: dst wait ready after 2
read_dst: reply is 0x9
 0x0 0x5 0x30 0x20 0x0 0x1a 0xdb 0x40 0x6d
dst_comm_init: Initializing DST.
dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
rdc_reset_state: Resetting state machine
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0000]
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0002]
writing [ 00 05 00 00 00 00 00 fb ]
dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
read_dst: reply is 0xff
dst_wait_dst_ready: dst wait ready after 2
read_dst: reply is 0x0
 0x5 0x0 0x32 0x0 0x5c 0x0 0x6d
dst_comm_init: Initializing DST.
dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
rdc_reset_state: Resetting state machine
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0000]
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0002]
writing [ 00 05 00 00 00 00 00 fb ]
dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
read_dst: reply is 0xff
dst_wait_dst_ready: dst wait ready after 2
read_dst: reply is 0x0
 0x5 0x0 0x32 0x0 0x5c 0x0 0x6d
dst_comm_init: Initializing DST.
dst_gpio_outb: mask=[ffffffff], enbb=[0001], outhigh=[0000]
rdc_reset_state: Resetting state machine
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0000]
dst_gpio_outb: mask=[0002], enbb=[0002], outhigh=[0002]
writing [ 00 05 00 00 00 00 00 fb ]
dst_gpio_outb: mask=[ffffffff], enbb=[0000], outhigh=[0000]
read_dst: reply is 0xff
dst_wait_dst_ready: dst wait ready after 2
read_dst: reply is 0x0
 0x5 0x0 0x32 0x0 0x5c 0x0 0x6d


There is one thing I didn't try, because I can't find:
> try changing the dst_tlist[]  (for DCT-CI )
> .type_flags = DST_TYPE_HAS_NEWTUNE | DST_TYPE_HAS_FW_2 
> only and see what happens.

I using kernel 2.6.14 r5 (gentoo)

Thanks for any help.

Jovana




More information about the linux-dvb mailing list