[linux-dvb] Tevion DVBT-220RF

brett coady bc1968au at yahoo.com.au
Mon Jan 16 02:57:48 CET 2006


Hi, Peter
Hi, Hartmut

Thanks for rolling the ball Peter I have been looking
at this on the weekend

I too have just purchased this card and also have it
using (card 81 but with tuner=54) and dvb module
loaded.

The card does not scan on analog for me however it
does manually tune if i pick a channel.

The card did output 1 dvb channel for myself but it
cannot scan or manually tune.

The way I can get the card on 1 channel is a bit
harsh:
I boot into windows and use the mediaportal opensource
program which knows the card. (its a kworld dvbt-220
equivalent)
then if i select close full screen the program crashes
leaving the card on the last frequency.
Then I reboot to linux without powering off and the
card is still on the last dvb frequency ! The card
then will only run if i pick that same frequency with
a dvb application on linux.

some logs:

saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18
ACPI: PCI Interrupt 0000:01:0a.0[A] -> Link [APC3] ->
GSI 18 (level, high) -> IRQ 20
saa7133[0]: found at 0000:01:0a.0, rev: 208, irq: 20,
latency: 32, mmio: 0xea003000
saa7133[0]: subsystem: 17de:7201, board: Philips Tiger
reference design [card=81,insmod option]
saa7133[0]: board init: gpio is 100
saa7133[0]: i2c eeprom 00: de 17 01 72 ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff
ff ff ff ff ff ff ff
tuner 0-004b: chip found @ 0x96 (saa7133[0])
tuner 0-004b: setting tuner address to 61
tuner 0-004b: tuner: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H
DVB-T)...

I get this output from VLC set to a channel:

main debug: `dvb:' gives access `dvb' demux `' path `'
main debug: creating demux: access='dvb' demux=''
path=''
main debug: looking for access_demux module: 0
candidates
main warning: no access_demux module matched "dvb"
main debug: creating access 'dvb' path=''
main debug: looking for access2 module: 8 candidates
dvb debug: Opening device /dev/dvb/adapter0/frontend0
dvb debug: Frontend Info:
dvb debug:   name = Philips TDA10046H DVB-T
dvb debug:   type = OFDM (DVB-T)
dvb debug:   frequency_min = 51000000 (kHz)
dvb debug:   frequency_max = 858000000 (kHz)
dvb debug:   frequency_stepsize = 166667
dvb debug:   frequency_tolerance = 0
dvb debug:   symbol_rate_min = 0 (kHz)
dvb debug:   symbol_rate_max = 0 (kHz)
dvb debug:   symbol_rate_tolerance (ppm) = 0
dvb debug:   notifier_delay (ms) = 0
dvb debug: Frontend Info capability list:
dvb debug:   inversion auto
dvb debug:   forward error correction 1/2
dvb debug:   forward error correction 2/3
dvb debug:   forward error correction 3/4
dvb debug:   forward error correction 5/6
dvb debug:   forward error correction 7/8
dvb debug:   forward error correction auto
dvb debug:   card can do QPSK
dvb debug:   card can do QAM 16
dvb debug:   card can do QAM 64
dvb debug:   card can do QAM auto
dvb debug:   transmission mode auto
dvb debug:   guard interval mode auto
dvb debug: End of capability list
dvb debug: trying to tune the frontend...
dvb debug: using inversion=2
dvb debug: using bandwidth=7
dvb debug: using fec=9
dvb debug: using fec=9
dvb debug: using transmission=0
dvb debug: using guard=0
dvb debug: using hierarchy=0
dvb debug: Opening device /dev/dvb/adapter0/dvr0
dvb debug: setting filter on PAT
dvb debug: Opening device /dev/dvb/adapter0/demux0
dvb debug: DMXSetFilter: DMX_PES_OTHER for PID 0
dvb debug: Opening device /dev/dvb/adapter0/ca0
dvb warning: CAMInit: opening CAM device failed (No
such device)
main debug: using access2 module "dvb"
main debug: pre buffering
dvb warning: no lock, tuning again
dvb debug: using inversion=2
dvb debug: using bandwidth=7
dvb debug: using fec=9
dvb debug: using fec=9
dvb debug: using transmission=0
dvb debug: using guard=0
dvb debug: using hierarchy=0
dvb warning: no lock, tuning again
dvb debug: using inversion=2
dvb debug: using bandwidth=7
dvb debug: using fec=9
dvb debug: using fec=9
dvb debug: using transmission=0
dvb debug: using guard=0
dvb debug: using hierarchy=0
.....and over and over....

whilst the above happens dmesg shows this:

tda1004x: found firmware revision 33 -- invalid
tda1004x: booting from eeprom
tda1004x: found firmware revision 23 -- ok

It would be nice to run this card under kaffeine on
more than just one channel ;-)

thankyou for looking at my post.

73
Brett
 




	

	
		
____________________________________________________ 
Do you Yahoo!? 
Yahoo! Photos: Now with unlimited storage 
http://au.photos.yahoo.com



More information about the linux-dvb mailing list