[linux-dvb] Compro DVB-T200 - question

Hartmut Hackmann hartmut.hackmann at t-online.de
Tue Jan 17 22:16:44 CET 2006


Hi,

raid517 at ukonline.co.uk wrote:
> raid517 at ukonline.co.uk wrote:
> 
>> raid517 at ukonline.co.uk wrote:
>>
>> > Hi I am using Debian Kanotix (Sid Unstable) with all the latest
>> > updates and kernel 2.6.15.1. I have a Compro DVB-T200 - saa7134-dvb
>> > vased card - but for some reason this does not appear to work.
>> >
>> > I was previously using a nova-t budget card - and this worked very
>> > well, so much so indeed that it required pretty much zero
>> > configuration (especially in Kaffiene) and worked more or less out of
>> > the box - but I gave that to my nephew as a gift included with a new
>> > PC over Xmas.
>> >
>> > My dmesg and lsmod output for the saa7134 card are attached. The
>> > driver appears to load fine, with no difficulties whatsoever - and I
>> > even have the correct firmware installed by default - which I think is
>> > dvb-fe-tda100046.fm (although there is no evidence in dmesg of this
>> > being uploaded).
>> >
>> > However there is nothing listed in my /dev section under DVB (such as
>> > /dev/dvb/video0, or /dev/dvb/adapter0 and so on). Indeed there are no
>> > DVB enteries in my /dev directory at all. (In the past these were
>> > always automatically created for me).
>> >
>> > Can anyone advise how best to get this card working? Is it likely that
>> > this card will this card ever work out of the box in the same way that
>> > my nova-t tv card did?
>>
>>  From a quick glance, it looks to me as if you hadn't loaded the
>> saa7134-dvb module - It does not load by itself.  Do:
>>
>> modprobe saa7134-dvb
>>
>> ...and it should take you a little bit further.  :-)
>>
>> Hope this helps,
>>
>> Yay! Success at last. Again not much configuration required by me. Now 
>> I just have to work out why there are a bunch of channels missing 
>> (BBC3, BBC4, History etc) that my WinTV Nova-T card could pick up.
>>
>> Thanks for all the help guys!
>>
>> GJ
>>
>> _______________________________________________
>> linux-dvb mailing list
>> linux-dvb at linuxtv.org
>> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>>
>>
> Mmm... Well there certainly does appear to be some tuning issues with 
> this card. About half my channels are missing - even though the Windows 
> version of the software for this card picks them up and even though I 
> can recieve them on my standalone DVB-T box.
> 
> Does anyone have any clues what might be going on?
> 
The reason might be the following:
In some countries, the providers shift some channel center frequencies
by + or - 167 kHz to overcome interference with analog channels. Some
channel decoders can lock with such an offset. With the current driver,
the tda10046 can't.
So please try to modify the frequencies for the channels you can't
receive. There is a very good chance that this works.
The other possible reason is that the configuration data in your config
file are not correct. The TDA10046 honours i.e. a specified guard interval
and will not lock if it is wrong.

Good luck
   Hartmut




More information about the linux-dvb mailing list