[linux-dvb] SAA7134 FlyDVB-T duo problem...

Federico Cozzi cozzi at dsch.units.it
Sun Jun 4 22:55:10 CEST 2006


Hi,
I've a lifeview flydvb-t duo but i'm unable to get it working under 
fedora core 5 (opensue 10.1: the same), the card was sold in bundle with 
a Targa laptop in Lidl shops...
Here is the dmesg log:
02:00.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 
Video Broadcast Decoder (rev f0)
Linux video capture interface: v1.00
saa7130/34: v4l2 driver version 0.2.14 loaded
PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 18 (level, low) -> IRQ 169
saa7133[0]: found at 0000:02:00.0, rev: 240, irq: 169, latency: 0, mmio: 
0x42000000
PCI: Setting latency timer of device 0000:02:00.0 to 64
saa7133[0]: subsystem: 5168:0502, board: LifeView/Typhoon FlyDVB-T Duo 
Cardbus [card=60,autodetected]
saa7133[0]: board init: gpio is 210000
saa7133[0]: i2c eeprom 00: 68 51 02 05 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 00 62 08 ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 ff 01 e4 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 24 00 c2 96 10 05 01 01 16 32 15 ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 1-004b: chip found @ 0x96 (saa7133[0])
tuner 1-004b: setting tuner address to 61
tuner 1-004b: tuner: type set to tda8290+75
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0

When i start to scan the stations with kaffeine (after i've loaded the 
module with: modprobe saa7134-dvb), i get this error message:
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision ff -- invalid
tda1004x: booting from eeprom
tda1004x: found firmware revision ff -- invalid
tda1004x: firmware upload failed

Should i've to upgrade the firmware? Where can i find  a new one?
Or the problem is somewehere else?
Many thanks in advance
Federico Cozzi



More information about the linux-dvb mailing list