[linux-dvb] No /dev/dvb/ with DViCO Fusion HDTV DVB-T Plus, Gentoo 2.6.16-r9

Michael Krufky mkrufky at linuxtv.org
Wed Jun 14 17:16:01 CEST 2006


Samuel Cook wrote:
> Apologies if this list is not the correct place for troubleshooting.  
> If it is not, please let me know and I'll redirect my queries elsewhere.
>  
> I'm having a lot of trouble getting my DViCo Fusion DVB-T Plus loaded 
> properly.  It appears to be the 1.1 revision (the chip ends with a -39 
> rather than a -19, which I believe is the indicator).  The card is 
> detected; lspci gives correct information about the card, and 
> /dev/v4l/video0 and vbi0 exist.  The problem is that /dev/dvb/ is not 
> getting created.
>
I believe your problem is simply due to the fact that cx88-dvb isn't 
loading automatically... try:

modprobe cx88-dvb

...then what happens?


> While I'm not a linux newbie, I am very green when it comes to 
> manually configuring hardware drivers and the like.  I've tried to 
> follow Chris Pascoe's instructions here ( 
> http://www.itee.uq.edu.au/~chrisp/Linux-DVB/DVICO/ 
> <http://www.itee.uq.edu.au/%7Echrisp/Linux-DVB/DVICO/> ), but to be 
> honest I'm a bit overwhelmed.
[snip .config]
> After building my kernel, I extracted this tar ( 
> http://linuxtv.org/hg/~pascoe/v4l-dvb?ca=cec41e698b97;type=bz2 
> <http://linuxtv.org/hg/%7Epascoe/v4l-dvb?ca=cec41e698b97;type=bz2> ) from 
> Pascoe's site and, as advised, followed the instructions on this page 
> ( http://www.linuxtv.org/repo/#build ).  The make section seems to 
> work correctly, but I get several errors during the make install 
> section.  The last one is:
>  
> install: cannot stat 'dvb-firesat.ko' : No such file or directory
> make: [dvb-install] Error 1 (ignored)
> /sbin/depmod -a 2.6.16-gentoo-r9
^^^ This indicates that you are using an extremely old repository.  
Instead, try building from the latest mercurial snapshot, as described 
in the linuxtv.org link above.

HTH,

Michael Krufky





More information about the linux-dvb mailing list