[linux-dvb] Cannot find any channels with dvbscan

joerg.marhenke at uni-ulm.de joerg.marhenke at uni-ulm.de
Fri Jun 30 12:18:30 CEST 2006


Hi!

I have no luck finding any channels with dvbscan. I'm using a Medion  
MD 95700 which seems to be recognized the way it should be:

dvb-usb: found a 'Medion MD95700 (MDUSBTV-HYBRID)' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software  
demuxer.
DVB: registering new adapter (Medion MD95700 (MDUSBTV-HYBRID)).
DVB: registering frontend 0 (Conexant CX22702 DVB-T)...
dvb-usb: Medion MD95700 (MDUSBTV-HYBRID) successfully initialized and  
connected.usbcore: registered new driver dvb_usb_cxusb

Furthermore, I'm using a self made aerial (a log periodic array) which  
works excellent with my DVB-T box on my TV. So reception should be ok.  
The whole thing used to work in Munich and Hanover and it works with  
the operating system that must not be named. The latest kernel I tried  
is 2.6.17.1. Curiously dvbtune yields the following output:

$ dvbtune -f 522000000
Using DVB card "Conexant CX22702 DVB-T"
tuning DVB-T (in United Kingdom) to 522000000 Hz
polling....
Getting frontend event
FE_STATUS:
polling....
Getting frontend event
FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_VITERBI FE_HAS_SYNC
Bit error rate: 0
Signal strength: 124
SNR: 65535
FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_CARRIER FE_HAS_VITERBI FE_HAS_SYNC

This does not look too bad, does it?
But when I try to scan for channels I get the following (no matter if  
in Stuttgart, Munich or Hanover):

$ dvbscan /usr/share/dvb/dvb-t/de-Stuttgart
scanning /usr/share/dvb/dvb-t/de-Stuttgart
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 522000000 0 2 9 1 1 3 0
initial transponder 706000000 0 2 9 1 1 3 0
initial transponder 730000000 0 2 9 1 1 3 0
>>> tune to:  
>>> 522000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: filter timeout pid 0x0011
WARNING: filter timeout pid 0x0000
WARNING: filter timeout pid 0x0010
>>> tune to:  
>>> 706000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE

And so on...
Is this a known problem? Are there any fixes or workarounds for this?
Thank you for your help!

-Joerg



More information about the linux-dvb mailing list