[linux-dvb] ttusb-budget: lost sync

Patrick Rother krd-linux-dvb at gulu.net
Fri Mar 17 11:53:31 CET 2006


Hi David.

On Fri, Mar 03, 2006 at 02:35:22AM +0100, "David Fröhlich" wrote:
> I just bought a new Hauppauge Nova-S USB. I compiled the latest kernel
> (2.6.15.5) to get the card working.
> The card works, but it's quite unusable, because the data stream
> has _many_ errors.
> I've found the following errors in the log:
> 
> ttusb_process_muxpack: muxpack with incorrect checksum, ignoring
> ttusb_process_frame: lost sync.
> ttusb_process_muxpack: cc discontinuity (2 frames missing)
> 
> Does anyone have this card working?
> Or does anybode have any hints how to solve this problem?
> 
> I searched and found this link:
> http://www.linuxtv.org/mailinglists/vdr/2004/05-2004/msg00274.html
> But unfortunately there was no solution.
> 
> I've no ideas, so: Please help me. :-)

I had discussed this with the author of the driver some time ago, and
came to the conclusion that my CPU is too slow or interupt wiring is
too suboptimal.
In the meantime I connected the device to several other machines, and
the problem still exists.

I don't know if this is a driver oder vdr issue.
vdr author Klaus Schmiedinger told me that vdr only request the
current channel data (i.e. not the complete transponder) from the DVB
device, so no USB bandwidth problem shall occur. If this is true,
there must be some driver problem, which I cannot debug myself due to
limited programming knowledge.

If anyone has more ideas, please let me know.

Thank you.



More information about the linux-dvb mailing list